Grasshopper

algorithmic modeling for Rhino

Hi!, 

 

I was preparing a model using Galapagos optimization algorithms and Geco+Ecotect to calculate the Fitness value.

 

I have no problem simulating a few elements shanding the facade, but running the problem with 25 sliders (3 possible positions each), galapagos send me an error when it's running for long time.

 

I've uploaded a screenshot with the error. Galapagos and Ecotect run and calculate 100 values and then the errors appear ( I guees that 100 values are 50pop*boost).

 

Using old Galapagos, Geco and Grasshopper there is no problem at all running definition.

 

Galapagos conf:

 

Using evolutionary solver.

Max.Stagnant: 40

Population: 50.

Boost: x2

Manintain: 5%

Inbreeding: 75%

 

25 sliders with 3 possible values: 0.01, 0.09, 0.018

 

Best Regards.

 

Ángel.

Tags: error, galapagos, geco

Views: 669

Attachments:

Reply to This

Replies to This Discussion

Hi Angel,

 

this is a bug, you need to replace the old Galapagos object with a new one, as Coupling types are not properly deserialized, creating a new object will fix this.

 

--

David Rutten

david@mcneel.com

Leusden, Holland

Trying right now! Thanks for the fast reply! 

 

Tonight I'm going to keep my computer running hopping a solution tomorrow in the morning :)

 

Best.

 

Ángel.

I hope you won't run out of memory until then :)

 

--

David Rutten

david@mcneel.com

Leusden, Holland

Good morning!, Enough free memory in my computer, but calculus are really slow (only 12 generations done in more than 8 hours)...4 local minimal found. 

 

Perhaps I've not setted correctly the values...50 generations with 25 sliders could be not necesary to find a good solution...

 

I'll keep the process running until afternoon.

 

Best Regards.

 

Ángel.

Hi,

I have the same problem because i was using an old version of GrassHopper. But now i have an other problem: Galapagos is not respecting the Max Stagnant number!

Using the old version of GrassHopper, i never had this type of problem.

Thank's,

Anis,

Attachments:

0.8.0066

5 stagnant and 5 population works for me

Hi,

I'm using Diva for Rhino and Galapags. I'm using the new version of GrassHopper and  i insert a new Galapagos component but i have always the same problem, Galapagos respect the Population parameter but not the Max Stagnant one.

Could you help me to resolve this problem.

RSS

Translate

Search Grasshopper

Photos

  • Add Photos
  • View All

Videos

  • Add Videos
  • View All

© 2014   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service