algorithmic modeling for Rhino

Hello Daniel i have downloaded and installed Kangaroo 2 but i cant interact with the rhino viewport, i have installed rhino 5 64 sr11, both files are unlocked, do you have any idea why this happens?

Views: 23633


Replies to This Discussion


Are you holding down the left Ctrl key on your keyboard while left clicking with the mouse?

Does the wire from the Grab component to the solver turn from orange to grey while doing this?

Yes, i am doing as you say, and the orange wire doesnt change, as dragging the pointer over the viewport it only appears as if i am selecting something with a dotted window, the ussual behavior in rhino

Ok, it sounds like the keypress event is not being detected.

Are you running Rhino on a Mac with VMWare or Parallels?

i am on a windows 7 64 and i already checked for net framework i have an updated version

Hmm, not sure then, sorry. I'll have to wait to hear whether it is working for others to try and narrow down the cause.

ah, one other thing you could try is turning COFF loading off (by typing GrasshopperDeveloperSettings from the Rhino command prompt and unchecking the box), and restarting Rhino

that did the trick! thanks, im testing it and its awesome! =)

Great! Thanks for your feedback.

i got the same error and used the same fix ,it all works now (also on windows7 64)

Love the Shell example !!

This new viewport grab is very cool!

Quick question, qhat if this option breaks all your old grasshopper definitions? is there a specific place to place everything?

Hi Jens,

The 2 files can go in the usual location - the one from

File>Special Folders>Components Folder

or if you prefer you can keep them in some other directory and add that in the GrasshopperDeveloperSettings.

Installing Kangaroo2 will not break older Kangaroo definitions, as you can keep the previous version installed alongside it.

Or do you mean specifically turning off the COFF setting - Are there some particular scripts or plugins that need it to be kept on?

Looking at this thread though, it seems maybe there is a way to avoid this problem:

I'll look into it some more...

Hi Daniel, 

Thank you for your quick reply. I tried turning off the COFF to get the mouseclick events to work, which then removed/unloaded(I do not know the right term for it) lunchbox,kangaroo 2 and human(the plugin not me). You know when you get a pop-up saying you are mising components when you open grasshopper.



Search Grasshopper


  • Add Photos
  • View All

© 2017   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service