algorithmic modeling for Rhino

Hi all,

I'm trying to planarize a mesh, but I can't. I've tried every thing and nothing happens, in some cases I got a warning about some index that can't be negative or something like that, in other cases the physics component stay gray but the out put geometry is invalid...

I made every connection combinations i could imagine, vertices, lines, meshes...nothing..

There is really few documentation or posts about it, and I'm lost, althougt it looked simple.

Please heeeeeeeeeeeeeeeeeeeeeelp¡¡¡¡¡

Uploading files....



Views: 4275


Replies to This Discussion


Sometimes, when something (in this case 'the planarize component') doesn't work, especially when you've tried every possible connection, it might just mean that it DOESN'T WORK! I'm assuming you're working with the latest kangaroo(0074), try the planarize component from an earlier version of kangaroo(0066) and it just might work.

Before anything, thanks for replying.

I was using 0066, and I have tryied 0074 also, nothing comes out.

Did you open the files?

Regards. Antonio


I think the planarize component doesn't work in kangaroo 0074 but it does in 0066.

I checked your files; and i've noticed that you;

- need to connect a timer to the kangaroo engine

- need to add spring forces (only planarize forces won't do the trick)

- your fixed points don't match any of your points that need to be planarized (your model might 'walk away')

I don't understand why you'd use a catmull clark component, why not use the hexagon from you hull component and i've you want your hexagons to follow your surface, use a pull to mesh/surface component.

I'll try everything you are tellling me although there are some that I have never used.

Thank you very much. A

Hi Wannes,

Nothing has changed in the code for the planarization force between version 0066 and 0074, so it would be very odd if there was any difference, and it's working fine in all my tests. Do you have any examples of it working in one version and not the other ?

Dear Daniel,

I have no examples but if I insert for example five random points to the vertices input of the planarize component (planarize any polygon) it has this runtime error;

"Solution exception: Method not found 'Boolean Rhino.Geometry.Point3d.Equals(Rhino.Geometry.Point3d)'.

This only occurs in Kangaroo 0074 

Hi Wannes,

Thanks for clarifying. However I still can't reproduce this error.

Which version of Rhino / GH is this happening in ?

Does anyone else have the same problem ?

Hi wannes,

I´m getting over this model again, but simplified.

Would you please chek this out, please?


no I didn´t. I used the first part of one definition I founded in one forum but it didn't get that far...I'm curious about that, it's really limilar if not the same¡¡¡






  • Add Photos
  • View All

© 2019   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service