Grasshopper

algorithmic modeling for Rhino

Shapefile still skewed in WSG84 - How to use userSRS ?

Hi Brian! 

Thanks for such an awesome plugin! I am new to working with GIS information and the Rhino/GH GIS workflow and I am experiencing some issues with importing a shapefile. I realized that the skewed nature of the shapefile was due to the difference in CRS ( mine was initially in NAD83. But i went into QGIS and reprojected it to WSG84/ Pseudo Mercator)  the ImportVector component reads the source file to have this CRS, but the building outline is still skewed. Any tips on how to fix this? I don't know what the issue is really... Attached screenshot and zip folder to shp. files! 

Views: 87

Attachments:

Replies to This Discussion

Hi!  I'm glad you're finding Heron useful.  Try setting the Earth Anchor Point (SetEAP) first before using ImportVector.  It seems to work when I tested it.  Also, you shouldn't have to reproject in QGIS, you should just be able to use the original shapefile.  I'd be curious to test this as well.  Can you post the original shapefile?

Attachments:

Hi Brian! 

I'm very happy to see such a progress with the development of your plugin. Great news! Looking forward for the documentation and other updates! However could you clarify how to use userSRS while importing shp files? I see WGS84 string input, EPSG:4326 string works as well. But other variants don't work. Is it possible now?

Evgeny

Hi Evgeny,

With Heron 0.3.6 you should be able to input a text string with 'EPSG:' and the code or the full projection string for userSRS.  See attached example using EPSG:5070 NAD83 / Conus Albers.  The Earth Anchor Point is in San Francisco, the polygons are in EPSG:5070 and the polylines are in WGS84.  Can you post a file you have had an issue with?

Brian

Attachments:

Hi Brian,

Here is a sample layer with buildings in UTM 37N (EPSG:32637). I has tried a string "EPSG:32637" but I have failed

I haven't realized yet what exactly userSRS will do for me, however the idea was to achieve results with no reprojection. Maybe you remember my question on that. I have found what I need in @it plugin actually (I need only to define a shift of a geometry in Grasshopper).  It is important when you are combining CAD-data and CAD modeling with GIS

Thank you for your time!

Hi Evgeny,

Yes, I remember now!  I'm not seeing the attachment.  Is there a link for the layer you can post?

Something went wrong... Here is the link https://1drv.ms/u/s!Ahy-UAuiRRxDg8EtUA8wgbguzsyDgQ?e=1bmccm

There is definitely a bug in my code here.  I'll have to look deeper.  What earth anchor point are you using?

I am manually adding LAT 55.75, LON 37.55 It is in Moscow. 

Hi Evgeny,

I have updated Heron to v0.3.7.  In this version, I fixed a bug in the ImportVector component which should allow the EPSG:32637 userSRS to work properly.  I've also added a CoordinateTranformation component to allow custom point transformations from any given SRS to any other in case that is needed.  Take a look and let me know if it works.

Dear Brian,

I think it works as I expected!

I set Earth point to 0,0 and I use 32637 and now the contours from QGIS export are matching those in Rhino (of course I have to move geometries closer to 0,0,0). These are hatches and selected ones. This is very critical when you are working in both CAD and GIS, while combining drawings from CAD with data in GIS. In other case you will get a slight nonlinear distortion that makes impossible to use it in CAD properly (black outlines).  Have to investigate this further, everything is not so clear for me

However it doesnt work without EAP, or with initial EAP 0,0,0.

Hi Brian and Evgeny,
I had the same problem while working on .SHP files in EPSG 2154.
I believe I found the solution to avoid distortion using the coordinate transformation command.
Here is the gh file where I imported your .SHP files :

buildings_EPSG_32637_1.jpg

buildings_EPSG_32637_2.jpg

buildings_EPSG_32637.gh

Thank you Paul!

Looks quite sophisticated! Could you clarify your needs? Have you tried my solution with EAP set to 0,0? From my point of view this is the way to get geodata in Grasshopper match the data from another CAD in the same coord system. 

For example I could get what I need exactly with @it plugin - just importing reprojected data in grasshopper and moving it closer to 0,0,0. Cadmapper service does almost the same - it reprojects geodata in a related UTM zone and relocates on of the corners of a bounding box to 0,0,0 with exact shift, so you could import that geometry back to QGIS.

RSS

About

Translate

Search

Photos

  • Add Photos
  • View All

© 2021   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service