algorithmic modeling for Rhino

Solution exceptionWindowsError in create_3dbuildings_trees_streets

Hello all,

This is my first time using Gismo and I'm having some trouble. I have a pc and am running Windows 10 and Rhino 6.

I previously wasn't able to get my the create3dbuildings_trees_streets script to work. I was getting an error message on the OSMshapes components. I searched the forums and followed these steps:

Close your Grasshopper and Rhino.
2) Restart your PC
3) When it boots up again, in your Start menu's search box type: "UAC". Click on it, and a new User Account Control Settings window will open. Set the bar on the left to "Never notify".
4) Completely turn off your Antivirus.
5) Check once again if your access control to the C:\MapWinGIS_installation_folder\gdal-data\osmconf.ini file is still set to the values you previously reported in this post.
6) Right-click on "Rhino 5" icon and then choose: "Run as administrator".
7) When Rhino boots up, run Grasshopper, and open the newest file from here.

This got the script to work and eliminated all of the error messages. The thing is...
The omsconfig file's settings switch back after a some time passes, so I have to keep going back to change them. Also If I don't right click on rhino and choose "open as an adminstrator" the script won't work. I'll get those same error messages when I open Rhino normally. I'm also not super comfortable turning off my antivirus software during the time that I am working.

Are there more permanant solutions that I can employ without going through these steps every time?



Views: 81

Replies to This Discussion

Hi Robert,

Try the following:

1) Close Grasshopper and Rhino.

2) Find your "MapWinGIS" installation folder (for example: "C:\Program Files\MapWinGIS".

3) Right-click on the "MapWinGIS" folder, then choose: 
    Properties > Security Tab > ALL APPLICATION PACKAGES
4) Click on "Edit" and then check all checkboxes in the "Allow" column of the "Permission for ALL APPLICATION PACKAGES" window!
Attached below is a 1.jpg screenshot of mentioned checkboxes. Screenshot is made for Windows 10.
5) Repeat step "4" for all other groups!!! Check the attached screenshot 2.jpg below to see which groups.
6) Repeat steps "3", "4", "5" on the following folder and file as well (in case you have "MapWinGIS" installed in: "C:\Program Files\MapWinGIS" of course):

    "C:\Program Files\MapWinGIS\gdal-data"
    "C:\Program Files\MapWinGIS\gdal-data\osmconf.ini"

7) Right-click on "Rhino 5/Rhino 6" icon and then choose: "Run as administrator".

If you have no issues after this, then close the Rhino and Grasshopper and try to run it 'normally', without the right-click on it and "Run as administrator".






© 2019   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service