algorithmic modeling for Rhino

Great job on the Gismo plugin! I find it really useful. I was wondering if you have any insight on the following error: WindowsError on all the OSMshapes component?

I managed to create the terrain using the analyse_terrain file, so I assume everything is working properly. Unfortunately, I am not able to create streets, building etc.

Please see attached image. Thank you in advance for our help. 

Views: 655


Replies to This Discussion

Hi starfx,

Can you show what kind of text goes out from the "readMe!" output please?

Hi, djorde. Here is the error text:

Runtime error (Win32Exception): WindowsError
line 378, in setupOsmconf_ini_File, "<string>"
line 529, in checkOsmShpFiles, "<string>"
line 920, in script

Thanks for your help!

Thank you for posting the text starfx.
The same issue has been reported last year, and solved.
MapWinGIS folder's had permission issues.

Try if that fix works for you as well:

1) Close Grasshopper and Rhino.
2) Find your "MapWinGIS" installation folder (for example: "C:\Program Files\MapWinGIS".
3) Right-click on the "MapWinGIS" folder,
then choose:
Properties > Security Tab > ALL APPLICATION PACKAGES > Edit >
and then check all checkboxes in the "Allow" column of the "Permission for ALL APPLICATION PACKAGES" window.
Attached below is a screenshot of mentioned checkboxes.

Screenshot is made for Windows 10.
If you have any other version of Windows 10, maybe there will be no "ALL APPLICATION PACKAGES" to choose. In that case you can try to select edit each of the groups.

4) Repeat step "3" on following folder and file as well (in case you have "MapWinGIS" installed in: "C:\Program Files\MapWinGIS" of course):

        "C:\Program Files\MapWinGIS\gdal-data"

        "C:\Program Files\MapWinGIS\gdal-data\osmconf.ini"

5) Run Rhino and Grasshopper again.

Please let us know the results

djordje, yes. That did the trick. Thanks!

Keep up the good work!

Glad it worked starfx!
If you have any other issues, please let us know!

Dear Djordje,

I am having the same error code and tried what you mentioned above, unfortuantely it doesn't change anything. Is there something else I can try?

Thanks in advance!

Hi Julian,
This issue is always caused by folder and file permissions.
Can you try to follow the upper steps again, but in the step 3, instead of "ALL APPLICATION PACKAGES" choose "Users (Desktop-***\Users)".
I attached a screenshot.


Hi Djordje,

That did the trick - Gismo is really an extremly helpful plugin, thanks so much!

All the best!

Hi Julian,
Glad it worked. Thanks for the kind words!






  • Add Photos
  • View All


  • Add Videos
  • View All

© 2022   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service