Grasshopper

algorithmic modeling for Rhino

Hello all,


Firstly I'm quite new to Gismo. I have a problem here to use the Gismo
After done with the installation of Gismo in Grasshopper, I tried to run it and as you can see in the attached photo, I can't run it because mapfolder input is invalid. I tried to have a quick look in the phyton script and it seems when it starts to search of  (Interop.MapWinGis.dll) and couldn't find it then this message will appear. 

Can someone explain to me step by step how to use or solve this, or perhaps any youtube tutorial using Gismo in grasshopper

Thank you so much!

Views: 87

Attachments:

Replies to This Discussion

Hi Iwan,

mapFolder_ is the path to 'MapWinGIS' installation folder.
Gismo will try to identify this folder by checking some of the common places, like C,D roots, C,D:/Program Files... and so on.
If it fails to find your MapWingGis folder, then you have to manually assign it.

For example, if you installed MapWinGIS to "E:/New Programs/2021/MapWinGIS", then the same path needs to be added to the "Gismo Gismo" component:


Let me know if this works.

Attachments:

Hi Djordje,

Thank you for the reply.

I follow the instruction provided by you, but it seems still to be invalid. I installed the MapWinGis as a default path which is C:/dev/MapWinGis. 

You can see as the attachment, the installation file, and the path connected to the Gismo node is the same.

Thank You

Attachments:

Hi Iwan,

Something is wrong with your installation, as I can not see the 'Interop.MapWinGIS.dll' file inside the installation folder.

Which version of MapWinGIS did you install? It shouldn't be newer than v4.9.6.1.

Do you have administrators rights on your PC? Or is that office PC?

1) Download Revo: https://www.revouninstaller.com/start-freeware-download, install it.
2) Uninstall MapWinGIS with it.
3) Download MapWinGIS from here: https://github.com/MapWindow/MapWinGIS/releases/download/v4.9.6.0/M...
4) Once the MapWinGIS file is downloaded, right-click on it, and choose: 'Run as Administrator'. Complete the installation.

Does that make any difference?

Hi Djordje,

It's finally working!! Thank you so much.

I'm installing the older version of MapWinGis. Before this, it's my mistake that I had a newer version installed. Thank you for your help!. :)

Best Regards.

I am glad it worked!

RSS

About

Translate

Search

Photos

  • Add Photos
  • View All

© 2021   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service