algorithmic modeling for Rhino

Hi to all

I want to try this plug-in. I have installed all requirements (Rhino 5, Grasshopper, Ghpython, MapWinGIS).

I have defined the MapWinGis folder because at the first attempt the installation folder was not recognized:

But now the panel displays this COM class factory error

I have followed all the instructions at point 1 without results.
Someone else has had the same problem? How can I solve?



Views: 3523

Replies to This Discussion

Hi Julian,
I am glad it works now!
To be honest, I didn't know that either. Is that your PC? How did you switch between these two accounts?

Hi Djordje,

haha, funny :)
i followed the instructions from this website and enabled the Admin account:



Thank you Julian.
If there are some other issues, let us know.

Hi Djordje, 

I've met the same problem as the reply. The code is 0x80070005 and I followed all steps to the end. But the CMD response is The specified path could not be found. Are there any solutions that can help this out :(

Hi Kerui Zhang,
Sorry for the late reply.
Can you please open a new topic? And post a screenshot(s) of that "he specified path could not be found" message.
Thank you.

Hi Djordje,

I have encountered the same problem while installing. And following the solutions mentioned above, in the end I created a new Administrator user account in order to use it. But the problem I have now is that, using my work computer, if I login as a network user with admin rights, I cannot use GISMO, but if I switch to a local admin user account, I can use it. This is happening on the same computer. 

Already tried the suggested steps multiple times. 

Is there a way to fix this so it can be used for any user on this computer?

Thank you,


Hi Wenyi,

Which error message did you get initially?
Which error message do you get now when you use login as network user with admin rights?

Hello, Djordje!

I had all the errors, described here before, i have fixed them, using safe mode, but then i got this one:
I have tried to search something about 8007007e, but had no succes

Thank you

Hi Daniel,

Sorry for the late reply.
Can you try following these steps.
At step 6, download the actual MapWinGIS v4.9.4.2 64 bit version from here.

Hey there old grasshopper forum. 

Let me be the stupid one once again... I followed the steps from the post and I can't somehow figure out how to get trough step 10...  I will really appreciate some help... thanks in advance!

Hi Angel,

Try this:

"C:\Windows\System32\regsvr32.exe" /u /s c:\dev\mapwingis\mapwingis.ocx

"C:\Windows\System32\regsvr32.exe" /s c:\dev\mapwingis\mapwingis.ocx

If you get an error again, It would be better if you would open a new topic about this issue.






  • Add Photos
  • View All


  • Add Videos
  • View All

© 2024   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service