Grasshopper

algorithmic modeling for Rhino

I've run into an issue with WB, and no amount of cheating is able to fix it.
Here's a brief preview of what's going on:


The version of GH installed is 0.60059, and WeaverBird can't seem to find it. And it strangely says its looking for version 0.6.43/55.. but I know it for a fact that it worked with this before because I had it installed. Version 0.2 of Weaverbird still finds this Grasshopper.. so there's something fishy in here.


I am finally looking at having GH 0.70048 and 0.60059 live harmoniously together, which is no problem at all -- but asking for WeaverBird on both seems to be a bit of nightmare.


Giulio, I hope you're tuned in.


Thanks,


Suryansh.

Views: 2110

Replies to This Discussion

[the first bit] looks similar to a problem i was having a few weeks ago ... does this help ?

http://www.grasshopper3d.com/forum/topics/weaverbird-not-fit-ghv060...

[check towards the end of the thread _ july.30]
Did you have a link in your post that you missed?
Hi Suryansh,

if for some reason the installer is not recognizing Grasshopper 0.6, just continue the setup.
Then, copy this file into Grasshopper's Components folder - often to be found in a path similar to this (you have it in the screenshot):
C:\Program Files (x86)\Rhinoceros 4.0\Plug-ins\Grasshopper\Components\
Finally, you will need to delete this file manually when uninstalling/updating WeaverBird 0.3.
Thanks,

- Giulio
Attachments:
Here something else you might be interested in:
all .msi installation files are some sort of an archive. You can open them with many tools, but a simple one is 7-zip.
If you go to http://www.7-zip.org/ and install it, you will be able to open the installation file and find weaverbird.cab. Inside of it is WeaverBirdBeak. Normally the files are named without extensions.

- Giulio
Thanks Giulio, that is very helpful.. and that information about the .msi extension is that added bit of geeky information that's going to be super useful in the future.

Thanks again!
Oh my, yeah, really cool!
Hi Giulio,

I've got weaverbird installed in Rhino, but I'm having difficulty getting the GHA to load.

The following error was generated after I went into the .msi file, pulled out the gha, and saved it in the correct folder.
Attachments:
Hi Kris,

the error list mentions "RMA.OpenNURBS.OnPlane" and other OnThings. This means that that gha is written for the old SDK (Grasshopper 0.6, as the file above) while it's being loaded from Grasshopper 0.8. You unfortunately cannot do this.

I'll go through the steps to uninstall the old version and install the new one with you.

- Giulio

Doesn't work.

I unblocked etc. I'm on windows 10.

Why does weaverbird use its own installer? Almost no other plugins do and it adds an extra level of complexity.

Hi Alex,

it has an installer because I got bored of telling people to unlock the file.

You can use the no-installer no-admin version. Please note that in Rhino 6, only the .GHA file will work, not the RHP.

You can place it everywhere, and make sure that the path added in _GrasshopperDeveloperSettings in V6.

Thanks!

Thankyou very much. I tried that earlier but it downloaded the same version - maybe the mistake was on my end. 

Thanks again

If you have a minute, 

What I'm trying to do is to create a regular mesh face on this trimmed mass. The Positive and Negative spaces are all made from 10'x10' nurbs boxes. So basically recreate all of these nurbs faces as a mesh with quads that are 10'x10'.

I understand I may have to reinvent the way I created this.

Please let me know if this is possible in Wb or if i should look elsewhere.

Attachments:

RSS

About

Translate

Search

Photos

  • Add Photos
  • View All

© 2021   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service