algorithmic modeling for Rhino


Hi everyone. I am new to Gismo. I currently installed it successfully but there is an error in reading the OSM file. I would appreciate it if you guide me in this regard.

Thank you again

Views: 859


Replies to This Discussion

Hi Niloofar,
Can you post the screenshot of the error message on OSM Shapes component?

Hi Djordje.

Thank you so much for reaching out to me for the response. I have attached two files. One of them is related to the error for the generating building, and the second one is related to terrain.


Hi Niloofar,
To create a 3D terrain with the 'Terrain Generator' component (that's your 2.png) photo, you need to get an API key, and add it to the '_APIkey' input. Here is a video tutorial on how to do that (click on 'Download' button, to start download of the video).

However, your 1.png shows a bigger problem: Gismo is unable to download required OSM data, because something is blocking its request.
Do you have Administrator rights on your PC/laptop where Gismo is installed?

Some time ago we had a user with a similar problem, and he solved it by contacting the IT department and asking them to unblock the "tcp port 9090". Maybe you can try to do the same?

Thank you Djordje! I will contact them to unblock it.

Dear djordje, the problem of blocking to download required OSM data solved successfully. However I can not have 3d shapes. I have attached the files screenshot. I would be so thankful if you let me know if I can have a 3d shape from the this location.(Abyaneh, Isfahan Province, Iran)


Hi Niloofar,
I am glad to hear that the download issue was resolved.
What does the message on 'OSM 3D' component say?

Dear djordje,

First and foremost, I am so thankful for your reply. It means a lot to me.

I tried it on my laptop one more time. There is no error anymore. That said, nothing special will be presented. I want to have the entire buildings in the village of Abyaneh in Iran and terrain topography. I believe that it is because no data in google Maps is visible. However, you can find all the buildings in the mentioned context on google earth.

I wondered if you have any suggestions for presenting the buildings and terrain since I want to evaluate the relationship of the buildings with the topography line.

Thank you again.


Hi Niloofar,
Gismo relies on open source data - openstreetmap for the buildings,roads,structures... and opentopography for the terrain.
Here is an example of what I got for 300meters radius for the buildings,roads and 600meters radius for the terrain:

Which corresponds to what openstreetmap is offering if you search for your location:

Google Earth is a commercial product, and it can have better data than openstreetmap and opentopography. There are people who are payed to create map content at Google Earth, while openstreetmap relies itself on volunteer work.
You can also contribute to openstreetmap - you can draw outlines of each building in Abyaneh village, and assign a number of floors to those outlines - this is a simplified way on how to add height information to openstreetmap buildings. I did this for example for my hometown. Once you do this - this data will be recorded and anyone else using either openstreetmap or Gismo will be able to benefit from it.
Here is tutorial on how to add number of levels information:
There is no tutorial on how to draw building outlines, but in the upper tutorial you will see a "Line" button starting from step number 4. It really is that simple, just draw four lines to make one building outline.

If you are not interested in mapping the Abyaneh village building outlines, then you would have to use some other plugin, like GHowl. It can import Google Earth meshes.

Thank you so much, djorje! I will try to follow your instructions to come to the conclusion.

I am thankful for your support as always!!

No problem Niloofar. Thank you from my part, for being patient with all the issues.

Now I have a question: The photo 1.png you posted yesterday: it showed inability of Gismo to download data from the internet (from openstreetmap).
How did you solve this issue? Did IT department tell you what was the problem?


Of course! I would be more than happy to answer any questions. The issue was my firewall that blocked access to the Internet. 

Ah, so. Did completely turning off the firewall solve the problem? Or did IT just added the permission to Rhino in Firewall list of allowed applications?






  • Add Photos
  • View All


  • Add Videos
  • View All

© 2024   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service