algorithmic modeling for Rhino

Map to Surface problem, slightly offset from target surface

Hi, I'm trying to map a voronoi to a 3d surface and it doesn't seem to be going exactly as planned.  The voronoi is always slightly offset from the surface, which causes an issue because I'm combining a few of these together on different surfaces, so there's not a gap where there shouldn't be.  It's always done this too me. 

Is this just a limitation in the map to surface command, or am I doing something wrong?

I've attached my files, but they're kinda a mess haha.

Views: 1192


Replies to This Discussion

Anyone out there?! haha.  I'm still stuck with this problem :|

Even on a way simpler object, projecting onto a flat plane, it also doesn't fill up the full target surface.  There is always a small "border" around it. :(  I'm lost

I'm not really seeing any problem with this.  I'm still using 0.9.0014 so I couldn't open your file successfully.


It's because the referenced surface you're feeding to your "Source" input is trimmed...I'm guessing you built it in Rhino as a planar surface...this is one of those things Rhino does which is a bit annoying.  You can see the gap if you look at your base surface and turn on the control points...they reside outside of trimmed edge.  You can fix this by building your surface from corner points (srfpt command) in Rhino, that'll give you a clean, untrimmed UV map to work from.

Thanks David, that worked.  In Rhino I created a UV surface for the spheres and then creating a planar surface like you mentioned.  

I don't know if I fixed it the easiest way haha,probably not, but I basically created an untrimmed surface like you said and then scaled it down to the size it was when it was trimmed, now it all works :)  






  • Add Photos
  • View All

© 2024   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service