Grasshopper

algorithmic modeling for Rhino

I've been attempting to produce continuous streamlines along a set of discontinuous lines. To do this, I've added a series of vectors along each line which the traveling points follow rather well.  The problem lies in the fact that I cannot get them to travel for more than one tenth of the distance I want them to.  I've been primarily adjusting the tolerance and the interpolation radius to attempt to remedy the situation.  I'm beginning to think that some means of restarting the interpolation (perhaps with a counter) is what I need to work it out, but am not sure how to do so or if that is the proper solution.  I've included the Rhino and Grasshopper file and would appreciate any feedback.  

Thank you,

Brett Watkins

 

Tags: SPM, Streamlines

Views: 521

Attachments:

Replies to This Discussion

Hi Brett,

 

I'm on it!

Great! I was hoping you might find some time to have a look.

Hi Brett,

 

Some general advice as I've just gotten into the office: One of the issue may be the LT (LifeTime) parameter on the integrator component. This determines how many 'steps' of the integration is performed before stopping. This parameter is necessary so you can control the integration manually, though it needs to be adjusted to suit your needs. Its default is 100 steps, but depending on the scale and other settings you will need to adjust it to suit the problem.

 

When you're doing a dynamic simulation with travelling particles, the LifeTime controls the step at which particles die, which is exactly where the integration stops in static integration mode as well.

 

Cheers,

Chris

Daniel and Chris,

 

Thanks for the quick response, that seems to have done the trick. 

 

Thanks again,

Brett

RSS

Translate

Search Grasshopper

Photos

  • Add Photos
  • View All

© 2014   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service