algorithmic modeling for Rhino

I am having a problem with honeybee where I get a runtime error when I place the honeybee icon in grasshopper.

My ladybug plugin works fine as well. I have installed the newest ladybug and honeybee.

The error I get refers to a Runtime error (win32Exception):WindowsError

The full picture is attached.

I recently did install the updated microsoft .net for another software and not sure if this is contributing to my problem. Any ideas?


Views: 664


Replies are closed for this discussion.

Replies to This Discussion

Hi Niel,

This is definitely a weird error.  It looks like the error is happening where the Radiance Material class is being initiated.  Do you have radiance installed on your system?


Hi Neil,

Thanks Chris. I think you are checking a different version of Honeybee_Honeybee. I tried to find the Honeybee version that you are using on Github ( and the error shows that the component fails to create the folder for Honeybee.

It is an strange error as working directory for Ladybug and Honeybee should be the same. Can you try the attached file and see if the error is still happening on your system?




Hi guys,

same error yet at a different line. See the attached image.


This is a permission issue and happening for the same reason.

Let's do this. If you check output of Ladybug_Ladybug component it should tell you where the default folder is set to. It can be C:\Ladybug or C:\Users\%USERNAME%\AppData\Roaming\Ladybug\. Can you check and see if the folder is already created? If not can you create it and let the Honeybee fly again?

Another reason that I can think of is the %USERNAME% on your system. Hopefully it doesn't have a white space.


I figured it out! It is definitely on my end so thank you for your prods to get me thinking about this further. Our local-user folders get setup with our username and then the office-server appended to our user-name folder.

So I have two folders, one that is USERNAME.IG and one that is USERNAME. Ladybug was looking at the latter, just user name, no strange extension. Yet Grasshopper and the components live native in the USERNAME.IG\AppData\Roaming\Grasshopper

I will definitely talk with my IT department about this and why exactly the .IG is necessary.

When I first step the added items under \ladybug, I figured it made the most sense to place the folder under .IG since grasshopper was in there. When I moved the \ladybug folder to where it was looking, honeybee is flying free!

Thanks guys!



I'm having a similar problem with my installation of Honey bee and I keep getting this error. Is it a permission issue. This is my pc. I tried loading and reloading this several different ways, including reinstalling it from instructions. Any suggestions?


Hi Herencia, Did you try to move your Radiance instalation to C:\Radiance and try again? I'm not sure if it will solve the problem but you need to do that to be able to run daylight analysis. If this didn't solve the problem let me know and I will try to help you to get it solved.

I had the same problem too.
It seems the reason was that my username which appears in the lockscreen was different from the username folder I had in drive C/users And ladybug default folder was set to the username folder which doesn't exist in C drive (the username that appears in lockscreen), so i created the address given in the ladybug_ladybug component and it seems the problem is solved.
Anyway I don't know if having different addresses for grasshopper and ladybug folders would cause any problem in the future or not.


I am having the same problem. I uninstalled and reinstalled the new version of LB+HB, and now I am getting "Win32Exception" error. From Radaince, Eplus and OpenStudio, I ONLY re-installed OSM again to save it in C:\program files rather than the automatic location that it selects. My radiance and Eplus are the same old ones. 

My radiance is located in C:\radiance

OpenStudio is in in C:\program files\Open studio

EnergyPlus is in C:\EnergyPlus V8.5

Would you please tell me what could be causing this error? 

I appreciate your help.



I wanted to add a note that when I connect a panel to my Honeybee component,  I see:

Failed to sort OpenStudio installation folders. I don't know if that is the problem or not. 




Search Grasshopper


  • Add Photos
  • View All

© 2017   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service