Grasshopper

algorithmic modeling for Rhino

Hello Everyone, so i am re-installing my grasshopper libraries after a windows format, and i am having trouble with some of the plugins one of which is kangaroo,

the error is the following

Exception System.NotSupportedException:
Message: An attempt was made to load an assembly from a network location which would have caused the assembly to be sandboxed in previous versions of the .NET Framework. This release of the .NET Framework does not enable CAS policy by default, so this load may be dangerous. If this load is not intended to sandbox the assembly, please enable the loadFromRemoteSources switch. See http://go.microsoft.com/fwlink/?LinkId=155569 for more information.

An error occured during GHA assembly loading:
Path: C:\Users\Gabriella\AppData\Roaming\Grasshopper\Libraries\Kangaroo.gha
Exception System.TypeLoadException:
Message: Method 'get_InitialOrientation' in type 'Grab' from assembly 'Kangaroo2Component, Version=2.0.1.0, Culture=neutral, PublicKeyToken=null' does not have an implementation.

An error occured during GHA assembly loading:
Path: C:\Users\Gabriella\AppData\Roaming\Grasshopper\Libraries\Kangaroo2.gha
Exception System.TypeLoadException:
Message: Method 'get_InitialOrientation' in type 'Grab' from assembly 'Kangaroo2Component, Version=2.0.1.0, Culture=neutral, PublicKeyToken=null' does not have an implementation.

I am sure that all .gha and .dll files are unblocked

what is weird is that only the meshing 2D shows in my kangaroo2 toolbar, whereas i am able to code in python by calling the dll file as in photo

Views: 80

Attachments:

Replies to This Discussion

Looks like it could be an issue with your .NET Framework and/or you Rhino Service Release not being up to date (or, maybe, that your .NET is TOO up to date, all though that is less likely). Try to check their versions and update accordingly.

Hej Anders,

so i am running Rhino

Version 5 SR13 32-bit
(5.13.60404.13390, 04/04/2016)

(some people are running earlier versions and it seems to be working fine for them)

and i have the latest  .NET Framework 4.6.2 installed

does it make sense to try and downgrade the .NET ?

(also the COFF in ghdeveloper settings is turned off)

ok, solved

turns out there was a wild Kangaroo.gha that is not kangaroo2.gha or kangaroo009.gha that was in my library for some reason and it was conflicting, not they work!

gabriella

Ah yes, that'll do it as well. You can use Everything to quickly search your system for stray .dll/.gha files if you ever come across this issue again.

great! thanks

RSS

Translate

Search Grasshopper

Photos

  • Add Photos
  • View All

© 2017   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service