Grasshopper

algorithmic modeling for Rhino

can someone help me figure out, what is happening here?
as soon as I've installed kangaroo, there are errors when grasshopper is loading...

I've followed the guidelines during installation (unblocking zip file, Kangaroo2.gha and KangarooSolver.dll)

what should i do?

thanks in advance for your time and answers

Views: 58

Replies to This Discussion

Hi Paul, this usually means you need to update Rhino to the latest service release.

Just to be sure, can you hit the "Export" button and attach the full errors here?

thank you for your reply "will".

my rhino version is "5 SR14 64-bit", i think, that's the latest version...

regards

Attachments:

It looks like it's having trouble finding KangarooSolver.dll. I apologise for repeating Daniel's instructions, but make sure it's in the same directory as Kangaroo2.gha and that it is definitely unblocked. It could also be a version mismatch. Kangaroo 2.3.3 is the latest version. I'd recommend downloading that and making sure to clean up any old versions of Kangaroo 2 that you might have.

i appreciate your help...
being on the same directory: done
definitely unblocked: done
(image attached)

i've already downloaded 2.3.3 from food4rhino.com/app/kangaroo-physics.
and before installation i've done cleaning up old version files from component directory. (even palnkton .dll files)

regards

I just installed Kangaroo 2.3.3 on a fresh machine with no problems. So we know that the issue isn't there.

I also tried replacing KangarooSolver.dll with the one from 2.1.4 (which was accidentally given the 2.1.3.0 version internally) and got exactly the same error that you have. So, it looks like Kangaroo2.gha (2.3.3) is trying to load KangarooSolver.dll (2.1.4 a.k.a. 2.1.3.0)...

Can you search the entire machine for Kangaroo2 related files (Kangaroo2.gha, KangarooSolver.dll, etc.) and delete them, then confirm that the KangarooSolver.dll in the Libraries folder has the correct (2.3.3.0) version ("Details" tab of Properties)?

brilliant, searching the entire machine did the trick.

for those who have the same issue:

there was a KangarooSolver.dll with 2.1.3.0 version on __os drive:\Users\"user name"\AppData\Roaming\McNeel\Rhinoceros\5.0\Plug-ins\Grasshopper ("some codes")\0.9.76.0\Components__

deleting this .dll did the trick and problem solved.

thank you "will"
best regards

RSS

Translate

Search Grasshopper

Photos

  • Add Photos
  • View All

© 2017   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service