Grasshopper

algorithmic modeling for Rhino

Animating Rhino Clipping Plane with Grasshopper

Simple C# script in Grasshopper 3d to change the position of a Clipping Plane in Rhinoceros 5.0.
More info: http://datable.net/animated-clipping-planes-in-rhinoceros/

Views: 1274

Comment

You need to be a member of Grasshopper to add comments!

Join Grasshopper

Comment by Gabriella Rossi on June 7, 2017 at 5:16pm

Thank you for sharing Luis

for those of you who struggle with C#, this worked for me

Comment by David Johnson on July 18, 2016 at 8:58am

Hey Luis,

A simple screenshot of the GH definition with the C# component would be super helpful!

Thanks

Comment by Deniz Yıldırım on February 3, 2014 at 11:58pm

I cant do it too because it gh c# does not let me to modify the first line of the script with gray background. Therefore it does not work and it give errors. Does anyone have a ghuser file for this script ? or a definition works well too i guess? 

Comment by BenjaminMoore on August 6, 2013 at 2:40am

This is great!

but I can't get it to work. What kind of geometry do you input in "y"?

I keep getting the following error message in the C# component:

Error (CS0029): Cannot implicitly convert 'Rhino.Geometry.Surface' to 'Rhino.Geometry.Plane' (line 72)

Any thoughts on what I'm doing wrong?

Thanks

Comment by Matheos Asfaw on March 22, 2013 at 7:00am

I just Tried it with Multiple machines as well. Both Mac and PC. im not sure why this is happening but would it be possible to upload the script on Grasshopper 3D? I would really appreciate it. 

Thanks and sorry for all the trouble. 

Comment by Luis Fraguada on March 22, 2013 at 6:37am

dunno what to tell you man.  Website comes up just fine on multiple computer / devices / browsers.

Comment by Matheos Asfaw on March 22, 2013 at 6:33am

yea. Got the same message there too. 

Comment by Luis Fraguada on March 22, 2013 at 6:28am

Have you tried to just go to http://datable.net?

Comment by Matheos Asfaw on March 22, 2013 at 6:07am

My browser keeps telling me that it couldn't connect to site. I tried Chrome, Fire fox, safari and IE all game me similar messages. Im not sure if im doing something wrong. Is there another way to access your site or to get a hold of the script. 

I really appreciate  the help. 

Comment by Luis Fraguada on March 22, 2013 at 5:29am

Tested the link, seems to work just fine...you will find the code there.

About

Translate

Search

Photos

  • Add Photos
  • View All

© 2019   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service