Grasshopper

algorithmic modeling for Rhino

Hi,

Just starting out with Wallacei, and it's great. Amazing documentation, very simple to use. Just tried it on a quick example file to go through all the tutorials, and it's working fine on the machine I'm on.

But I can't get it to run with the attached file. Can anyone tell me what I'm doing wrong?

It's a very rough first sketch of something that will hopefully become more interesting later on, based on Chris Mackey's Ladybug+SkinDesigner tutorial. Genes are three breps that rotate incrementally. A solar radiation study is performed on the vertical (wall) surfaces of the resulting geometry. The two objectives are to minimise the rotation while maximising the beneficial sun falling on those surfaces. I've tried to internalise stuff, but you'll probably have to plug in a new epw file for the analysis to run.

I'm sure I'm being very stupid here, but I've been banging my head against the wall for too long. Very helpful for any pointers.

Thanks! 

Views: 176

Attachments:

Replies to This Discussion

Hi Magnus,

I ran your definition and it works fine here.. you mention you 'cant get it to run', can you clarify..?

Hi Mohammed,

Many thanks for responding so quickly.

Great news that you can run the definition at your end.

Sorry about the slightly rushed message before. What happens is this: absolutely nothing. As I mentioned, Wallacei runs just fine when the process is less heavy, but as soon as I try to throw this slightly more intensive analysis definition at it, it crashes Rhino. I click on the Wallacei X component and get the control window, set the generation size and count to something sensible (like 5/10), hit Start, and watch as the window stays the same for about a minute, and then throws an error message at me and kills the program.

Thoughts?

All best,

Magnus

Are you using rhino 5 or Rhino 6?
Also, can you give me more info on your setup? ( type in the rhino command _systeminfo and paste the result here)

I'm on Rhino 6. No longer in front of my computer, but will check first thing in the morning and get back to you. Really appreciate your help.

Good morning Mohammed,

Hope all is well. So here's the system info:

Rhino 6 SR9 2018-9-28 (Rhino 6, 6.9.18271.20591, Git hash:master @ 4cf7435f08f51c972347c8558d28355cfc0471ca)Rhino 6 SR9 2018-9-28 (Rhino 6, 6.9.18271.20591, Git hash:master @ 4cf7435f08f51c972347c8558d28355cfc0471ca)Licence type: Educational, build 2018-09-28License details: Stand-Alone
Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)Machine name: KTH-6845
Intel(R) HD Graphics 530 (OpenGL ver:4.5.0 - Build 23.20.16.4973)
OpenGL Settings  Safe mode: Off  Use accelerated hardware modes: On  Redraw scene when viewports are exposed: On    Anti-alias mode: 4x  Mip Map Filtering: Linear  Anisotropic Filtering Mode: Height    Vendor Name: Intel  Render version: 4.5  Shading Language: 4.50 - Build 23.20.16.4973  Driver Date: 2-28-2018  Driver Version: 23.20.16.4973  Maximum Texture size: 16384 x 16384  Z-Buffer depth: 24 bits  Maximum Viewport size: 16384 x 16384  Total Video Memory: 1 GB
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp "Commands" 6.9.18271.20591C:\Program Files\Geometry Gym\Rhino3d\BullAnt.rhp "bullant" 1.4.4.0C:\Program Files\Rhino 6\Plug-ins\rdk.rhp "Renderer Development Kit" C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp "AnimationTools" C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp "RDK_EtoUI" 6.9.18271.20591C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp "Renderer Development Kit UI" C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp "Snapshots" C:\Program Files\Rhino 6\Plug-ins\IronPython\RhinoDLR_Python.rhp "IronPython" 6.9.18271.20591C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp "RhinoCycles" 6.9.18271.20591C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp "Grasshopper" 6.9.18271.20591C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp "Toolbars" 6.9.18271.20591C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp "3Dconnexion 3D Mouse" C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp "V-Ray for Rhino" C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp "Displacement"

Look forward to hearing from you,

m

Hello again Mohammed,

Just a quick note to check if the above specs gave you any hints as to why Rhino crashes when I try to hook up the definition I posted to Wallacei? 

All best,
Magnus

Hi Magnus,

Ive looked at your definition some more and found some parts that MAY be causing the issue.. its difficult for me to find exactly the problem as when i run it as it runs fine on my machine (and so i will need your help in debugging through asking you to run a few tests on your machine (the machine that is crashing ofcourse)).

Ok firstly, the 'Gencumulativeskymatrix' component for ladybug takes about 30 seconds to compute (on my machine at least), and when you run wallacei, the canvas (and all active components on the canvas) recompute for each solution being generated.. and so if you have a component(s) that take very long to compute, and if you do this for every iteration, it may overload your system causing it to crash. Having said that, you dont need to calculate the skymatrix every iteration, you can calculate it once and then internalise the data being inputted into the 'RadiationAnalysis' component.. (see image below) before running Wallacei. I attached for you the definition where i already did this, and so if you can try it and report back that would be great.

Secondly, I noticed that there is a component on your canvas that automatically bakes geometry into your Rhino Scene everytime the canvas recomputes (and so as above, this means that every solution being generated by Wallacei, geometry is being baked to your canvas). The component is 'SkinDesigner_SkinGenerator' (see image below).. i am not familiar with the skin generator plugin, and so im not quite sure how to stop it from baking the geometry onto the rhino scene but if you can find a way to stop this please do so and run wallacei again, this is what may be causing the crash. if you cant find a way to do this, please make sure you are in wireframe mode before running the simulation, that should atleast make it a bit lighter, but im uncertain if it would actually help!).

Can you please run tests with the above and report back? (please run Gen size 3 and gen count 3 to start with).

190308_paper-iv_EXPERIMENT-A_190321_TEST.gh

Hi Mohammed,

First: many thanks for taking your time to help me solve this. I really, truly appreciate it.

I've internalised the 'Gencumulativeskymatrix' component, disabled the SKY part of the definition, and made sure I'm in wireframe more before testing a 3x3 solver run, but Rhino still crashes. So it appears that is probably not what's causing the issue.

Haven't figured out a way to make sure SkinDesigner stops drawing those previews, but will check now with Santiago who authored it to see what can be done, and will report back to you as soon as I know.

Again, many thanks for your very kind help with this. And for writing such an ace plug-in.

Best wishes,

Magnus

Hello again Mohammed,

Got hold of Santiago, who told me how to disable the baking (see attached file). Unfortunately, this is still not working, not even with everything internalised/disabled as above, post-restart with display settings at wireframe (tried the "Don't draw any preview geometry" mode as well) and the parallel computing option in the radiationAnalysis component switched on/off. Hm. Not quite sure what to try next. Ideas?

Attachments:

can you run Wallacei in the attached file.. im trying to slowly debug the definition and find where the problem lies.. this is a simple definition that uses ladybug on a simple box... please report back if it runs without problems

LB_Test.gh

Hi again Mohammed,

So grateful that you're setting time aside to help me with this.

Yes, once I change the epw from Perth to my local file for Stockholm, this works fine. Tried 3x3 first, then 25x3 - no crashes or other issues. 

What might the next step be?

Many thanks,

Magnus 

RSS

About

Translate

Search

© 2019   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service