Grasshopper

algorithmic modeling for Rhino

Wallacei X Component Vanished After the Simulation is Finished

Hi guys

I have run a simulation to achieve 6000 solutions. When it was finished I saved the file and opened later and I realised the wallacei component is missing and also I received this error from Grasshopper when I open it.

"Plugin version: 1.0.0007

Component Wallacei X {31c3b95d-be66-41aa-9219-9fda28c0b847} failed to deserialize itself: Array dimensions exceeded supported range."

Any idea what might cause the problem?
I need to mention I have run the simulation of a 64bit PC with good specifications. 

Many thanks

Views: 78

Replies to This Discussion

Hi Saam,

This is because you are opening a simulation you ran in an old version of Wallacei using the latest version - (Simulations ran in pre V2.4 won’t open in newer versions) if you open the simulation in the same version you ran it then it should open fine (I.e. uninstall the current version of Wallacei on your machine and install the older version).

Hope it helps,
Mohammed

Hi Mohammed,

Many thanks for your reply.

I ran the simulation again and when it was finished I could see the solutions and use the component. However, when I saved and closed the file and opened it again, the Wallacei X component was gone! 
Basically, I opened the simulation which was run on the same version of Wallacei X and Rhino. One thing which is also strange is that the file takes a long time to be saved.


Any suggestions?

Hi Saam,

Can you make sure you are running the latest version of Wallacei and check if that solves the problem (I.e. run the simulation in the latest version and then check that it opens after restarting rhino)

Hi Mohammed

Thanks again for your reply.

I made sure that I have the latest version of the rhino:

Wallacei V2.5 (17 November 2019) - Rhino 6
2020-Feb-03
Grasshopper Win 6


I did the simulation again and strangely it works right after it is finished by the moment I restart the rhino to open the saved file the component disappears with showing the error I mentioned above.

Hi Saam,

It seems the volume of the data stored in the file crashed the grasshopper de-serialisation method. Theoretically, the data from 6000 solutions should not be able to exceed the max range of the .Net Array. Can you provide further information to us for investigation:

1, the size of the gh file

2, the number of objectives and number of genes you used for the model.

3, if possible, share the simplified gh file with us. We can debug it from our side.

Best,
Yutao

Hi Yutao

Many thanks indeed for your support,

The size of the file is 4.42mb before and 151mb after the simulation.

Regarding the genes, 19089 values are inherited from 36 sources.
Regarding the objectives, 6 values are inherited from 6 sources.

I have attached the files for before and after the simulation.


I also need to mention that when the simulation is finished the file works fine. the moment I save a copy of it and close and open rhino file the components disappears with the error I mentioned above.

Please let me know if you need the file after the simulation and I can send you. I could not upload it here to due to the limit on file size.

Many thanks for your help again.

Hi Saam,

 

We studied and debugged your file, and the following is what we have found and what we recommend you to move forward.

You have more than 19000 genes, and you ran the simulation for a population size of 6000 individuals. The reason for the increased file size is the excessive number of genes you have in your simulation as well as the size of the population (as you know Wallacei stores the DNA of the entire evolution, that is why we can have access to the evolutionary history of the simulation).

When you save the file what happens is that this data is going to be kept in the file and when you open the file, this data will be decoded back to Grasshopper file. In this scenario, the data for your simulation (because of the number of genes as well as the size of the population) has exceeded the max range of .Net array in windows. In other words, it exceeded the capacity of windows to write and read this data. This primarily happened because of 19000 genes. I should mention that I ran your simulation for a smaller population size of 400 and everything worked just fine. So now given this info, the following is what we suggest:

  • If you are very keen on keeping 19000 genes involved in the simulation. You should either
    1. Run your optimisation problem for smaller population size.
    2. If you want to have 6000 individuals again, after simulation finished, internalise the fitness objectives coming out of the WallaceiX component and save it in another file. By doing so, you can run a thorough analysis of your simulation anytime even after closing down your GH file by using Wallacei Analytics component.
    3. When your simulation finished, do all your analysis, selections and exports processes from within WallaceiX UI before closing down the file, because as you saw, the data can’t be stored in the file in your scenario and you will encounter the same issue.

 

  • Nonetheless, we really recommend you to rethink and reformulate your design problem. Having 19000 genes, not even caused this data storage issue but also it exponentially increased the size of the search space. In the scenarios with the large search spaces (in your case a very large) the optimisation problem won’t be efficiently solved. When I ran the simulation for a size of 400 individuals, none of your fitness objectives was optimising correctly. This indicates that the design problem needs to be revisited and restructured. Maybe you need to break down your problem into smaller sizes problems. The most important part of the application of multi-objective optimisation processes in design is how to formulate the question.

 

Hope it helps

Best,

Milad

Dear Milad, Mohammed and Yutao

Many thanks indeed for your awesome support. I just did as Milad said and it is solved.

Much appreciate your help guys...
All the best

RSS

About

Translate

Search

Photos

  • Add Photos
  • View All

© 2020   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service