Grasshopper

algorithmic modeling for Rhino

I can't see all sliders as input in "No. of Genes (sliders)" [SOLVED]

Hi all,

thank you for your work!

I am trying to run your basic tutorial, but I have noticed that my Genes sliders don't take into account all pool sliders connected to "No. of Genes (sliders)" - so I can't see any solution generated by WallaceiX.

It seems to not recognize pool sliders.

Maybe I missed something - Thank you in advance. ( I am using RH6 SR11)

Views: 103

Replies to This Discussion

Hi Luciano,

We are trying to recreate the problem according to the screenshots you sent but were not able to. Can you please confirm that you did the following:


1. ensure that you unblocked all the dlls that are in the 'WallaceiX' download folder before copying the folder to the libraries folder.
2. Copy the WallaceiX (with all the dlls and gha within it) to your Grasshopper Libraries folder.

If you did the above and you are still facing the problem, please save your gha file and send it to us so we can have a closer look.

also, do you have rhino 5 installed on your machine? if so, can you try opening wallaceix in rhino 5 and testing it.

Thank you for your quick answer,

I confirm that all dlls are unblocked as your installation instructions say. I have reinstalled my RH v5 and all works like a charm. Unfortunately, on my RH v6 I am still facing the problem.

Example%20File%20-%20Wallacei%20X.gh

thank you for sending the file over.. we checked it on our systems and all seems to be ok. which means we may need to go through some troubleshooting with you and try to resolve this issue. 

1. connect all the sliders and genepool, open the UI and click reset.

2. if you didnt try already, can you delete the existing wallaceix component from the gh canvas and use a new one and connect all sliders/genepools to it.

3. Can you hover over the genes input (after you connect the sliders) on the walaceix component and see if it has values there (see image).

4. open a completely new gh file and test the wallaceix component.. please follow this short 1 minute video tutorial: 

https://www.youtube.com/watch?v=FMSXTwmQQcE&list=PLFTtKqY0JOrs6...

once you run through the checklist above, can you report back if any of the above has worked to resolve the problem.. if so great! if not, then we move on to stage 2 of trouble shooting!

 

Thank you,

Following your checklist:

1. Done. I am still facing the problem.

2. Done. I am still facing the problem.

3. I can see the values hover over the GH component (see image below)

4. Done. I can see the values hover over the GH component (see image below) but I am still facing the problem.

We tried again to recreate the issue with different PCs and laptops but unfortunately we could not, everything seems to be working fine with our tests. Our only guess is that there might be something related to the installation of rhino on your pc. Re-installing your rhino 6 might be helpful and may resolve the issue, and so if you are willing to give it a shot, then it may be worth it. however, without access to your pc it is difficult for us to find the source of the problem. 

(as a side note, I notice in your screenshots that you are using the command _unloadplugingrasshopper .. this command is not functional in rhino 6, to unload grasshopper and successfully load a plugin, you must restart rhino 6)

if you type in _systeminfo in your command line in rhino and send us the text in the popup window, we may  be able to further trouble shoot, but this may be a long shot. 

You mentioned that it is working in rhino 5, which is good as there are no major performance differences when running wallaceix in rhino 5 or rhino 6.

if more people report this issue, (and its not a standalone instance of this problem), we will look into it further and invest more resources into resolving it.

in the meantime, if you face any other issues, (or have any questions about running wallacei) please let us know and we will be more than happy to help!

Thank you for your support,

I have tried to repair and reinstall Rhino 6, but unfortunately, I am still facing the problem. However, my Rhino 5 works fine. I will continue to stay tuned on Wallacei and to wait for further feedback about this kind of issue.

I have attached my systeminfo txt as you have requested.

Thank you again.

systeminfo.txt

Hi Luciano,

We looked into this further and have released an update that should now resolve this issue. In the Wallacei download page on the food4rhino website (link below), we have uploaded 2 versions of Wallacei, one that is compatible with Rhino 5 and one that is compatible with Rhino 6. If you download the Rhino 6 compatible version, and try it in Rhino 6, the genepool issue should be fixed.

https://www.food4rhino.com/app/wallacei-0

Please let us know if you face any other issues,
Thanks once again for raising this!

Hi Mohammed,

Thank you. Now seems to work all fine. 

RSS

About

Translate

Search

Photos

  • Add Photos
  • View All

© 2019   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service