Grasshopper

algorithmic modeling for Rhino

1. You downloaded Ladybug, Installed it but as soon as you drag a component into the canvas you see something similar to this:

You probably don't have GHPython installed on your system. Download GHPython and install it and it should work fine.

2. You still see the image above in case 1 however you have GHPython already installed. What about that?

In this case probably the GHA component is blocked. Find GHPython.GHA on your system (usually at: C:\Users\%username%\AppData\Roaming\Grasshopper\Libraries) . Right click, go to properties and select unblock.

To make sure that GHPython is working fine on your system open the attachment file (testGHPython.gh). You should see something similar to the image below on your screen when you open the file:

If you see the something similar you should be fine to go! Try to open one of the example files.

3. You have Ladybug running but in some of the case the output is missing. You see something similar to this:

or this

This one is because you are using old version of GHPython. Close the file without saving. Download the new version and install it and re-open the file. It should work fine now.

Hope it helps,

Mostapha

Views: 20810

Attachments:

Replies are closed for this discussion.

Replies to This Discussion

nice ¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡

right now it works perfectly

thank you so very much

Cool! Thank you for letting me know :)

Thank you for your post

Sorry for bothering with an annoying issue.

I have installed latests grasshopper (0.9.0069), phyton and ladybug.

When I try to use any ladybug component there is a strange behaviour: I can drop any component on the canvas but only once; the second time I try i get the warning that "the user object could not be created as the base type is missing" (see attached screenshot). Same thing happens when I try to add components to an old definition that contains ladybug components.

What could be wrong?

Thanks a lot in advance. 

Attachments:

Hi Giorgio,

Thank you for reporting this. What happens if you drop a standard Python component to the canvas? It looks like an issue with GHPython component.

- Mostapha

Thank you Mostapha for replying.

I tried to use the a test component for Phyton and actually it happens the same thing: first time I use it works, second time it does not ...

Shall I post this issue somewhere else?

Strange thing is that everything was working up to yesterday, today I installed the latest grasshopper and it stopped working.

Giorgio

Attachments:

I see. So it is an issue with the GHPython component in the new version of Grasshopper. It maybe because I'm using the older version of GHPython. I will send a message for Giulio to see if he has any inputs on this one.

It would be great if you also post it as a separate discussion. Other users may have some insight.

Thanks,

- Mostapha

thank you, I'll do that!

I was having this problem too with ghpython  0.6.0.3.

Going back to ghpython 0.5.101 seems to be the sweet spot, works with the Ladybug 0.0.53 release and the latest Grasshopper.

Saeran 

thank you Saeran, actually it works!

Giorgio

I'd like to know more about this... I do not think this should happen. I've answered Mostapha's question here.

Thanks,

Giulio
--
Giulio Piacentino
for Robert McNeel & Associates
giulio@mcneel.com

Giulio, I don't think older version of GHPython causes the problem. I received a number of emails that updating to 0.6.0.3 cause similar problem. In all the cases downgrading to 0.5.101 solves the problem. Do you have any idea why this is happening? -Mostapha

RSS

About

Translate

Search

Photos

  • Add Photos
  • View All

© 2019   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service