algorithmic modeling for Rhino

Testing using the example files from the workshop last week to rule out definition error.

Installed Dragonfly, MatLab compiler 9.0, and UWG per instructions. When I try to run the UWG component, I get this for a few seconds: 

And then the simulation stops without running through anything additional in the command prompt than what is above. The EPW file is generated but it is 0kb and empty. I imagine something in my set up is not correct but I haven't the slightest idea what it can be. The is a UWG folder in the AppData/Roaming/Ladybug folder.

Views: 441

Replies are closed for this discussion.

Replies to This Discussion

Hi Elliot,

It looks like the UWG is hitting an error.  Do you have admin privileges on this machine?  Also, what version of Windows is running?

No admin privileges. Running Windows 7 Enterprise

I have a feeling that the admin privileges are the root of the issue.  Could you try right-clicking the Rhino icon before you launch it and hit "Run As Administrator", get someone to type in an admin password, and then try running the GH script?  I know this is what solved a lot of the issues with running OpenFOAM with Butterfly and it might work similarly here.

Got admin rights, still no dice. Any other suggestions?


I've the same issue. The EPW is empty. I'm running Windows 10 and Rhino 5 as admin. A screenshot that shows the error is attached. It shows traceback: line 232, 382, and 410. 

BTW:I'm running Butterfly without any issues.


Mohammed and Elliot,

This issue is most certainly the result of the MATLAB compiler failing to run correctly on your system and I should put in a better warning for this (rather than missing epw file).

Mohammed, in your case this is because the MATLAB runtime compiler version 9.0 is not meant to run on Windows 10 systems.  I have been talking with the people who currently maintain the UWG and have access to MATLAB.  They should hopefully add this support soon.  

Elliot, in your case, I still don't know what the issue might be.  Are you sure that you installed the 64-bit version of the MATLAB Runtime Compiler?  I might be able to recreate your issue on one of the machines at my office and I will try to do this soon.  If I can re-create it, I should hopefully be able to fix it or figure out the issue relatively quickly.

At the latest, both of you will be able to run everything when we finally transition to a python version of the UWG at the end of this summer.


Hi all,

Can you check to see if MATLAB is generating a crash dump file for these runs and post it here? It might be easier to debug it that way.

In Windows, look for a file matlab_crash_dump.XXXX (with XXXX being a process ID) in:



Thank you, Saeran. The error logs would be really useful.

Hi Chris, Saeran, and Elliot,

I think I found what is issue !! Elliot, try if this is the same issue that you have.

The UWG component could find the file path because the epw file has different name than the one the UWG component looks for. The epw file is generated but empty. As you can see in the screenshot below that the error is

"1. Solution exception:Could not find file 'C:\Users\Test\AppData\Roaming\Ladybug\SampleCity\UWG\SampleCity_SGP_Singapore.486980_IWEC.epw'.

and the file that was created has numbers after IWEC (IWEC-641-61024.epw). To make the component works, I deleted the numbers after IWEC from the file name to match the file name the component looks for and rerun it again. By doing that, I got the component runs but again the name changed to be "SampleCity_SGP_Singapore.486980_IWEC-641-61024.epw" as you can see in the second screenshot. 

I've to do the same process every time I need to run the analysis. I don't know if this issue can be fixed from your end or something to do with my computer.

Thank you,


That's weird. That kind of sounds like a similar issue I was having with Dragonfly a while ago. I eventually managed to hunt down the issue by going through the the error logs with Chris, and finding an incompatibility with the matlab dependency and my graphics driver. The fix was to do clean install of new drivers, and also change the profile the driver uses.

I have no idea if this is why your problem is occurring, but I'll paste the solution I used here in case it helps you or anyone else:

Unfortunately, the fact that the actual UWG algorithm is written in Matlab makes it really difficult to debug and solve these issues right now. The good news is that it is being rewritten in Python as we speak! Once that is done, and the matlab dependency is gone, I think these issues will either disappear or be a lot easier to resolve.

For my case with Windows 10, there is no a crash dump file in: C:\Users\$YourName$\AppData\Local\Temp

I will try to have a fresh installation on Windows 7 and see if I can run it. I will post if I get something different.  



Hi All,

I tried the example file using Windows7 and Rhino 5 as admin. I have the same issue and there was no a crash dump file created !!








  • Add Photos
  • View All


  • Add Videos
  • View All

© 2022   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service