Grasshopper

algorithmic modeling for Rhino

Hi guys,

I am trying to make the full environmental for a bridge but when I choose OSM shapes it told me that:

1. This component requires OSM data to be downloaded from openstreetmap.org. It has just failed to do that. Try the following two fixes:

1) Sometimes due to large number of requests, the component fails to download the OSM data even if openstreetmap.org website and their services are up and running.
In this case, wait a couple of seconds and try rerunning the component.

2) Try lowering the "radius_" input.

I try it to rerunning the component again and again but nothing changed. I also made the radius smaller until it allows me and it doesn't work neither.

Thanks in advantage!

Best regards,

Patricia

Views: 69

Replies to This Discussion

Hi Patricia,
Can you show also what is coming out from the "readMe!" output of the "OSM Shapes" component?

Just plug in Grasshopper's yellow panel to "readMe!" ouput, and post a screenshot of it.
Thank you.

Yes, of course :) Is something similar: Capture.JPG

{0;0}
0. downloadFile_e1: Unable to connect to the remote server
1. downloadFile_e2: [Errno socket error] getaddrinfo returns an empty list
2. This component requires OSM data to be downloaded from openstreetmap.org. It has just failed to do that. Try the following two fixes:

1) Sometimes due to large number of requests, the component fails to download the OSM data even if openstreetmap.org website and their services are up and running.
In this case, wait a couple of seconds and try rerunning the component.

2) Try lowering the "radius_" input.

If each of two mentioned advices fails, open a new topic about this issue on: www.grasshopper3d.com/group/gismo/forum.

Thank you very much for your time and your attention :)

Best regards,

Patricia 

Hi @djordje again :)

Now I download everything in other computer and the problem now is in the comand GISMO - GISMO. It said that:
0. Runtime error (MissingMemberException): 'LightException' object has no attribute 'components'
1. Traceback:
line 43, in script

And I don't have idea of how to fix that. 

Hi Patricia,
Thank you for posting the warning message.
It essentially means that something is blocking Rhino's access to internet.
It can be a lot of things: a local firewall, antivirus, lack of administrators rights, or blocked port.

As for your second problem:


"0. Runtime error (MissingMemberException): 'LightException' object has no attribute 'components'
1. Traceback:
line 43, in script"


It is caused by an old ghpython component. You need to have at least version 0.6.0.3. Download it from here.

RSS

About

Translate

Search

Photos

  • Add Photos
  • View All

© 2019   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service