Grasshopper

algorithmic modeling for Rhino

Hi to all

I want to try this plug-in. I have installed all requirements (Rhino 5, Grasshopper, Ghpython, MapWinGIS).

I have defined the MapWinGis folder because at the first attempt the installation folder was not recognized:

But now the panel displays this COM class factory error

I have followed all the instructions at point 1 without results.
Someone else has had the same problem? How can I solve?

Regards,

F.

Views: 459

Replies to This Discussion

Hi Francesco,

Sorry to hear you are having this issue. Thank you for posting the screenshots.
Indeed the same issue happened on my friend's PC during testing stage. For some reason the MapWinGIS application (which is a prerequisite for running Gismo components), either haven't been registered to Windows registry, or your Windows operating system lacks some .dll file which prevents MapWinGIS .dlls from running.

If I understood you correctly you followed both "1a" and "1b" steps? So you installed the Revo Uninstaller Pro, and used it to remove MapWinGIS?

If this is correct, then can you please provide the following information:

a) which Rhino version, service release and which bit version
(in Rhino, choose Help -> About Rhinoceros)

b) which Grasshopper version
(look at the bottom right corner of your Grasshopper window)

c) which ghpython version
(open an empty ghpython component, or any Gismo component and look at its bottom right corner)

d) which Windows operating system and which bit version
(example: Windows 8.1, 64 bit)

​e) open the attached file below, and tell us what it prints in the yellow panel.

Thank you for all the answers!

Attachments:

If I understood you correctly you followed both "1a" and "1b" steps? So you installed the Revo Uninstaller Pro, and used it to remove MapWinGIS?

Yes I followed both 1a and 1b steps. I have installed and used Revo uninstaller Pro to remove MapWinGis:

a) Rhino 5 SR12 64-bit

b) 0.9.0076

c) 0.6.0.3

d) Windows 10, 64 bit

e) version: 2.7.0 ()

version info: (2, 7, 0, 'beta', 0)

isUserAdmin: 1

Thank you for detailed reply Francesco.
Everything is ok with your software and plugin versions.

Can we  try a couple of things please?

Download the Total Commander "Windows 64-bit only" version from here.

Run it.

In your left window, go to "c\dev\MapWinGIS" folder.
In Total Commander's application menu, choose: Commands -> Open command prompt window.
A command prompt window will open. Type:

regsvr32 mapwingis.ocx

and hit Enter. Do you get any error message?

command unrecognized:

Gismo runs on a Windows 7 32 bit OS (the other informations as for the previous case):

Maybe the problem is MapWinGIS because when I try to run it in a machine with windows 10, 64 bit, the command prompt opens and closed rapidly. on the contrary, with the machine with windows 7 OS and 32 bit architecture, when i click on reg MapWinGIS.cmd, the command prompt appears regularly.

Hi Francesco,

So on your another PC, with Windows 7 32 bit, your Gismo components work with no problem. On your Windows 10 64 bit, you have the CLSID upper issue?

On your Windows 7 32 bit, you installed "MapWinGIS v4.9.4.2 Win32" version?

On your Windows 10 64 bit you installed "MapWinGIS v4.9.4.2 x64" version?


command unrecognized:

...

Judging by this post on stackoverflow, regsvr32 still needs to be used even in case of 64 bit. I do not understand why is that error raised.

Can you try to search through your hard drive for "regsvr32.exe"?
When you find it, can you try to use the following command:

"your_regsvr32_folder_path\regsvr32.exe" "c:\dev\mapwingis\mapwingis.ocx"

So on your another PC, with Windows 7 32 bit, your Gismo components work with no problem. On your Windows 10 64 bit, you have the CLSID upper issue?

it's correct

On your Windows 7 32 bit, you installed "MapWinGIS v4.9.4.2 Win32" version?

it's correct

On your Windows 10 64 bit you installed "MapWinGIS v4.9.4.2 x64" version?

it's correct

Maybe this link can help

Thank you for the detailed reply.

Can you try to search through your hard drive for "regsvr32.exe" on your Windows 10 PC? And then repeat the previous mentioned step in Total Commander (Commands -> Open command prompt) and type the following command:

"your_regsvr32_folder_path\regsvr32.exe" "c:\dev\mapwingis\mapwingis.ocx"

If my Google Translation of error message in Italian was correct, then this answers.microsoft.com topic suggests that Error code 0x80070005 means: "Access Denied", as if you do not have administrators rights to register the "mapwingis.ocx" file.

Francesco, would you be patient just a tiny little bit, so that we could try something else? I would be grateful if you could.

1) Close Grasshopper and Rhino
2) Run the Revo Uninstaller Pro and uninstall your MapWinGIS application along with removing all the leftovers from the registry.
3) Restart your PC, and once it boots again, make sure that you are logged in as an Adminstrator.
4) In your Start menu's search box type: "UAC", which will find your User Account Control Settings. Click on it, and a new window will open. Set the bar on the left to "Never notify".
5) Turn off your Antivirus, which ever it is.
6) Download the 64 bit version of v4.9.4.2 MapWinGIS.
7) Right click on downloaded MapWinGIS-only-v4.9.4.2-x64.exe file, and choose "Properties". If there is "Unblock" button click on it, and then click on "OK". If there is no "Unblock" button, just click on "OK".
8) Left double click on MapWinGIS-only-v4.9.4.2-x64.exe file and install it to "C:\dev\MapWinGIS" folder. Choose "Full installation" during installation process!
9) In your Start menu's search box type: "CMD". Once the "Command prompt" appears do not left click on it! Instead right click on it, and choose "Run as Administrator".
10) A command prompt window will open. Type the following command:

"your_regsvr32_folder_path\regsvr32.exe" /u /s c:\dev\mapwingis\mapwingis.ocx

If command does not result in an error message, then type this one afterwards:

"your_regsvr32_folder_path\regsvr32.exe" /s c:\dev\mapwingis\mapwingis.ocx

11) If no error appeared again, then open your Rhino and Grasshopper and check what Gismo_Gismo component prints from its "readMe!" output.

If errors appeared, it would be nice if you could post their screenshots.

Solved! Thanks to djordje!

Glad it worked Francesco!

I guess you can get the UAC and Antivirus back to "on" now.


We are eager to hear your future suggestions about Gismo!

Same issue on a Windows 10 PC with AMD Ryzen 7 1700X Eight-Core Processor and 16 GB of installed RAM. I have also tried to follow all the steps reported in this topic.

RSS

About

Translate

Search

Photos

  • Add Photos
  • View All

© 2019   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service