Grasshopper

algorithmic modeling for Rhino

Hi all,

I'm wondering if anyone has experience using Firefly with Arduino compatible boards (or if it's even possible). The uArm's Uduino board behaves like an Arduino Uno, but I haven't been able to read or write to it successfully yet.

The Firefly Firmata uploaded successfully and I've attempted to write to the Digital Pin 10 through 13, which are what powers the arm's Servo-controlled axes. (This is an assumption drawn from the Servos being connected to "D10" through "D13" on the uArm Shield.)

Also, when using the [UnoRead] component I receive the following error:

1. Solution exception:Conversion from string "" to type 'Integer' is not valid.

Any ideas?

Thanks in advance. Looking forward to troubleshooting this.

Cheers,

/SPM

Views: 567

Replies to This Discussion

I hadn't seen the UArm before... looks cool.  It seems like if it can communicate over Serial, then it should definitely be possible.  It's possible that the Firmata would need to be modified slightly in order to work properly.  This is probably an obvious question, but have you uploaded the Firefly Firmata to the Uduino board before trying to send commands to it?  Is there any documentation on the actual board you're using (not just the shield)?

Hi Andy,

Thanks for the reply. Yes, I did upload the Firmata to the Uduino board, though I did not attempt to modify it.

I haven't found any significant documentation on the Uduino board itself. The "Getting Started" document doesn't mention writing to board at all, for instance. Maybe the Github Repository will help.

Because the board is based on the Arduino Uno, I (naively, perhaps) tried to use the uShield with a Firmata-loaded Uno, to no avail. If I'm reading this thread correctly, theoretically it should have worked.

Thanks for your help,

/SPM

Hi!

this is my MeArm+Grasshopper+Arduino Project https://youtu.be/HO9ZNX_UGkw

maybe I can help you with connection FireflyToArduino
but maybe it is better for Skype

Hi Stephen

I was wondering if you had managed to get this going? If not I would be happy to troubleshoot this with you as I have managed to read from and write to uArm's Uduino board. However if you have managed to get it running, well done! I am currently in the process of attempting to send a G-code or similar to the arm, I was wondering what experiments you have been able to run if you have managed to resolve your problem.

RSS

About

Translate

Search

Photos

  • Add Photos
  • View All

© 2019   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service