algorithmic modeling for Rhino

I'm a bit of a newbie to grasshopper and are trying to create a solar radiation analysis of my building. 

When creating a simulation though grasshopper it says "You are not connected to the internet..."

I am using a MAC!

I initially thought it was related to my active firewall, however, once disabled, still no change.

URGENT request, Please help me out. 

Thanks people :)

Views: 487


Replies to This Discussion

Hi Callum,

You could download the epw file to your pc and load it using the 'open epw' component instead of using a URL



Hi Fillippos,

So I downloaded the epw file as you suggested, however when I run it through the Ladybug_GenCumulativeSkyMtx, it fails to recognise the mtx (I checked the ladybug folder and no mtx file was produced). I'm hypothising that this could be due to the gendaymtx.exe or GenCumulative sky.exe due to them not being able to run on macs (I could be wrong however).

The epw file itself seems to work and I'm also able to aquire this mtx file from a colleague of mine. Do you have any alternatives as to how I can either;

a) Run the GenCumulativeSky Component

b) Insert the separate mtx file (aquired from my colleague) into my grasshopper script.

Thanks very much for your time and I shall insert my colleagues email should you require him aswell.

With regards,


Colleague :


Hi Callum,

**Dont know about mac.

Your units were in mm so the grid size you were trying to analyze was way too small..

Add your epw and a well made massing and you should be fine









  • Add Photos
  • View All

© 2021   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service