Grasshopper

algorithmic modeling for Rhino

wafle structure | Intersection of planar surfaces doesnt work properly

i remixed the wafle tutorial on digitaltoolbox.info. i modified it to make it work on more abstract forms and in order to use cnc milling.
as soon as i have "holes" in the geometrie the intersect doesnt work properly.
is there any way to solve this?

take a look at the attached files.


cheers


ramon

Views: 416

Attachments:

Replies to This Discussion

I think mine used to work with holes.

Give it a whirl if it still works:

http://fancywires.com/?p=59
I had the same problem. I followed the same tutorial and I think in my case, it didn't work because the two series of surfaces (or curves) that you perform the intersection on did not correspond correctly with one another. You get multiple surfaces on the same plane (as a result of the holes you mentioned) which messes the intersection up.
So I think it is a problem of the data structure of the series of surfaces. Try flattening the data, or something like that. I haven't had time to figure it out myself and I wont for a while. I'll pm you if I do though. Let me know if you find a work around.
hey guys! thanks for that quick reply!

@mischa
i know. i tried already all kind of datatree treatment....

@taz
amazing work!
i tried a simple shpere and it seems like that its still a bit buggy

RSS

About

Translate

Search

Photos

  • Add Photos
  • View All

© 2022   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service