Grasshopper

algorithmic modeling for Rhino

Hi,

I have rhino 5, sr3 and i just upgraded to grasshopper version 0900054. that doesnt load and get stucked at loading vector.

Where cen i download version 090014 and revert back to it ?

thanks a lot

Views: 1894

Replies to This Discussion

I even have to restart windows every time since the task manager can't quit the process...

That is just bloody weird. I'm digging deeper, nothing to show for it yet.

--

David Rutten

david@mcneel.com

Poprad, Slovakia

UPDATE: It  seems to be a parallels issue here. Sorry for the fuzz. I use a windows7 on bootcamp installation, either booted in parallels or native bootcamp, but it is the exact same installation in both cases.

The above mentioned behavior (fail to start GH) does not show when booting in bootcamp (only in parallels)! That's good news on the one hand, on the other, I started to like parallels since it just started to work for me after all those years of periodical trials.

advices still welcome. 

I'd love to know what's causing it, but I have a feeling we may never find out. This is exactly why McNeel officially doesn't support Parallels and VMWare, because you always get these mystery crashes and I don't think we've ever been able to figure out why.

It's extremely suspicious that 0.9.005+ is suffering from this whereas the older version is not. The explanation that seems most plausible is the .NET framework though. 0.9.005+ is build on .NET 4.0, earlier versions were build on .NET 3.5

But again, why this might be causing such problems is anyone's guess.

--

David Rutten

david@mcneel.com

Poprad, Slovakia

Hi david,

thanks for the effort. I aware of the fact that I use parallels on my on risk, so thanks again for checking! I found out, as mentioned before, that in some (maybe all) cases it seems to be a matter of patience. I didn't us ea stop watch, just left the seemingly hanging process alone and check back after a while, and voila: it eventually loaded. Everything that takes more than 15 second is nowadays considered seriously broken... I will monitor this more closely and let you know.

I am running windows computer and have still having same issue.

David,

I am also using parallels and had trouble with grasshopper hanging at 100% load.  When I uninstalled the automatic windows 7 updates that were made when I first set-up Parallels and Windows 7, grasshopper loaded without a hitch.  

For other users with the same problem, http://www.sevenforums.com/tutorials/24373-windows-update-uninstall....

Hope this helps,

Jackson

Hello David,

I also have troubles loading the latest GH and even the debug built does not run.

Attached you see the screenshot and what is written in the comand line.

I hope for a quick sulution for this bug!

best,

Martin

This happened one or two times with me,  magicaly, switchind to desktop (windowsKey + D) and back into rhino solved the freezing...

Im having this proablem too with the latest version...

it happens all the time and the only truck I found is to Delete the "Roaming/Grasshopper" folder... (like start fresh...)

Tasos

+1

The issue only appears in Parallels. Grasshopper boots fine under Boot camp. Have tried downloading .NET 4.5 and this did not solve the problem.

Kendra,

My temporary solution until the next build has been to delete the entire roaming/appdata folder before launching grasshopper.  It may be possible to delete everything but the plug-in library. I'm not sure. I haven't investigated too closely.

Jackson

+ Another datapoint for bug tracking

The bug seems to be related to evaluating license acknowledgement using Bootcamp under Parallels.

After a reboot of the Windows machine under Parallels, Grasshopper will crash and will force you to restart the Windows machine.

If you remove the Grasshopper directory under User > AppData > Roaming before launching Rhino / Grasshopper for the first time after a reboot of Windows under Parallels, Grasshopper will prompt you to acknowledge the license agreement. Acknowledge the license agreement, Grasshopper will boot normally.  Close Grasshopper / Rhino. Copy your Libraries folder back into User > AppData > Roaming > Grasshopper. Restart Rhino, Grasshopper. Grasshopper should load normally with all of your plugs.

This seems to be extremely repeatable.

RSS

About

Translate

Search

Photos

  • Add Photos
  • View All

Videos

  • Add Videos
  • View All

© 2020   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service