Grasshopper

algorithmic modeling for Rhino

hi there,

i would like to read data columnwise like its suggested in this thread.

http://www.grasshopper3d.com/forum/topics/reading-a-multicoumn-csv-...

but using this example i get an error balloon

(1. Line 37: Von der ParseLine-Funktion wird kein Wert in allen Codepfaden zurückgegeben. Wenn das Ergebnis verwendet wird, kann während der Laufzeit eine NULL-Verweisausnahme auftreten.) sorry for the german , maybe you can figure out.

i use Version 0.9.0076

thy very much

Views: 5513

Replies to This Discussion

can you upload a sample of the data?

That will make helping much easier.

hey there,

thy for the reply.

for example i used the given files in the post i linked. my csv file has basically the same structure.

ok. I got that csv sample from your link... reset the file path to the correct place on my machine... and had the same issues as you. So then I replaced both the components at the beginning of the definition and things seemed to work fine.

It may just be something has changed with our newer version of GH... or some other reason that escapes me.

Hope this helps.

Attachments:

works ! thank you very much

hey,

im facing another problem, the content of the colums is interpretet as text not as string, even if they are numbers...

Text and String is the same thing. Programmers call it strings, regular people call it text.

All data inside a panel (the big yellow things) is text data. If you plug numbers or points or anything else into a panel, what you get a textual representation of that data. Sometimes the text can be converted back into other data again (colours, points, numbers, booleans), but there is no guarantee that you'll get back exactly the same data. Especially decimal numbers tend to be rounded when they are converted into text, which results in loss of information.

so are programmers non regular (irregular) people? hehe.

sorry for confusion,

grasshopper didnt read for example 3,5 as a number.

this was what i got from my csv file. so the solution was to fix this in the open office editor options, where you can say if you like to have point or comma as your format. ( eg 3,5 or 3.5)

RSS

About

Translate

Search

© 2022   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service