algorithmic modeling for Rhino

Hello community! 

My first post here. 

I made a simple open-curve in rhino and made copies in Gh... moved it in z, scaled it.

I've made sure the loft sequence is correct. But the Gh loft is giving result thats excluding the middle curve.

I coudnt figure why this happening. the curves are all fine. to check, i baked them and used Rhino loft and it worked perfectly. 

Can someone help me whats happening here? Wht am i doing wrong in Gh? Or is it a bug. For now m managing with rhino-loft but i hate doing that. 


Views: 3399

Replies to This Discussion


Probably it's because of the different path input from "Scale" component.

You can fix this by checking "Principal" option from the I/O Modifiers of input "G".(right click on the "G"(Geometry)input of Scale component's context menu and choose "Principal")

It would be easy to explain if you post your definition with internalised your referenced curve or along with your rhino file.

Hey that fixed it! Thank you!

Hey Rama

I would say your problem is likely a data structure issue. The control point (CP) function modifies the branch indices as you can see in the param viewer in the top right corner of the image. The loft will only loft data items which are in the same list, so in order to ensure that all items are being fed into the loft in the correct order and the correct branch, we flatten each input in a merge.

As you can see, the second loft gives you the desired output.






  • Add Photos
  • View All

© 2024   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service