algorithmic modeling for Rhino

At present Grasshopper should run on Rhino 4.0 (SR8 or later), Rhino5 32-bit and Rhino5 64-bit. However, the Grasshopper installer only informs Rhino 4.0. You'll need to install Grasshopper on Rhino 5.0 manually. 

Additionally, while running on Rhino 4.0, Grasshopper requires the .NET 3.5 framework to be installed. Rhino 4.0 does not ensure this so there may be a cryptic error. You can download and install .NET 3.5 from the Microsoft website.

While running on Rhino 5.0, Grasshopper requires the .NET 4.0 (or newer) framework. Rhino 5.0 does check for this so you will be duly informed if you do not have .NET 4.0

First, try the easy installation procedure, if that doesn't work, try the more difficult one.

  1. Locate the GrasshopperPlugin.rhp file. It should be in <ProgramFiles>/Rhinoceros 4.0/Plug-ins/Grasshopper, but it may be in a different folder depending on the access privileges of your Windows account.
  2. Start Rhino 5.0
  3. Drag+Drop the GrasshopperPlugin.rhp file into the Rhino 5.0 viewport
  4. Grasshopper should now be installed and you should be able to run the _Grasshopper command.

If the above doesn't work, you may need to copy the entire Grasshopper plugin folder into the Rhino 5.0 Plug-ins folder before loading it using the same steps outlined above. Note that once you manually copy the files, they will not be uninstalled or updated automatically either.


David Rutten

Poprad, Slovakia

Views: 106151

Replies to This Discussion

Thanks David!

Dear David,

I followed your instructions to run Grasshopper on Rhino5 but the icons doesn't appear when i run Grasshopper.

Drag+Drop the GrasshopperPlugin.rhp file into the Rhino 5.0 viewport. The command line indicate 

File "C:\Users\mnsrgl\AppData\Roaming\McNeel\Rhinoceros\5.0\ui\VRayForRhinoV4_tb.rui" is already open.

But when i run the _Grasshopper command, this error window appears


and icons of Grasshopper are missing.

I also tried by copying the entire Grasshopper plugin folder into the Rhino 5.0 Plug-ins folder but  i have the same problem: icons are missing.

any suggestions?

Thank you

What date is your Rhino5 beta from? You probably need to update to a newer version.


David Rutten

Poprad, Slovakia

Same problem here, David. I copied and pasted my GH plugin folder from Rhino 4 into Rhino 5, as you described above. (Did not try the drag and drop, since I found your advice after I copied the files). GH is v 0.90014  RH5 is dated 9/27/12

May I ignore this message without any complications until a solution is determined?  Out of curiosity, is it easy to tell the GH installer where to install (Rhino 4 or Rhino 5)?  Even more deliciously, one install for both R4 and R5?  :^)

Maybe the problem is from Firefly, since that's where it stalled upon load? I have to click CLOSE in the pop up five times to dismiss it. In all cases, the messages are empty.  Maybe this helps you diagnose what's up?  ~David Celento

Problem solved! It was an older version of Firefly.

Strangely, the Firefly files were not in the GH Components Folder. I dragged them out of the Rhino 5 Plugins folder to the desktop. GH still found and loaded them at launch.

I downloaded the new Firefly, and followed the installing and unblocking instructions below from Andy. When I launched GH it found the old and new and asked me what to do. I deleted the old and GH now launches without the Breakpoint Message.

To install FireFly (required only once): ---------------------------------------- • Launch Rhino and type the word ‘Grasshopper’ in the command line. This will launch the Grasshopper Editor. • Click on File>Special Folders> Components Folder • Delete any prior versions of the Firefly.gha or Firefly_X.gha build files or the libTUIO.dll or C_sawapan_media.dll files that may be in this folder. • Open the Firefy Installation folder that was just downloaded (in the zip folder) and copy all the contents of the Firefly Build folder (Firefly.gha, Firefly_X.gha, Firefly_Bridge.dll, libTUIO.dll, and C_sawapan_media.dll) into the Components Folder that was opened from within Rhino. • Now, Restart Rhino and Grasshopper ******NOTE: If you are having problems getting Firefly to load properly in Rhino 5.0 beta****** • Open the Special Components folder (where we just copied the 5 files) and right-click on each file and select "Properties". Under the General tab, check the box to "Unblock" the file. Do this for each of the three files. • Now, Restart Rhino and Grasshopper

Thanks David!

It seems to be working at the moment other than a few add-ons that have not been updated to work with new version of Rhino 5.



Ok, I followed these instructions while installing grasshopper some time ago. Now some complements for grasshopper (lunchbox e.g.) need a newer grasshopper release that the one i currently have. I've tried everything but all updates keep going to rhino 4, not rhino 5.

Maybe there's an obvious and simple way to make this work, but I just can't find it.

Thanks in advance!

Dear David :

I'm facing this Problem .. what should I do ?

How old is your Rhino5 version? If the InitializeRhinoCommon function is missing (as it seems to be) it's way old. In fact it would be so old it should have expired long ago so it's a bit odd.

If that;s the case you'll need to update to a newer release.


David Rutten

Poprad, Slovakia

Hi there, I have a problem with the installation of grasshopper on my Rhino 4.0 SR8. I installed the release 9 in order to upgrade it and I followed all the instructions, but this is the message I get...which asks for the latest version from the provider...Any clue? thx

Grasshopper 0.9.X does not run on Rhino4. It requires Rhino5.


David Rutten

Poprad, Slovakia

does it mean I cannot install grasshopper anymore if I don't get Rhino 5?






  • Add Photos
  • View All

© 2020   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service