algorithmic modeling for Rhino

I feel like I'm missing something obvious. I'm reading through the SDK documentation on how to create a custom Grasshopper component. I've created the class library, inherited from GH_Component, built the dll, and renamed it to a GHA file.


But how do I tell grasshopper to load my GHA file?



Views: 31253

Replies to This Discussion

That video was outdated. Today the Grasshopper SDK documentation file and the Wizard are the right places to start building a GHA assembly full of components.


Giulio Piacentino
for Robert McNeel & Associates

Hi i have installed several plugins that don`t seem to work correctly.

I have always put all of the files into: the Component folder which is called "Libraries" when opened.

Is it correct to put the ".dll"-files also in this folder?

Plugins that don`t work are for example: "DecodingSpaces" - tells me "Tektosyne.core" was not foud although it`s there. (it is a ".dll")

"Mosquito" tells that "Newtonsoft.Json" was not found. Also a ".dll"

Thank you for your help!

Is the COFF loading option enabled in your _GrasshopperDeveloperSettings command? If yes, can you disable it and restart Rhino+GH?

Hi David, thanks for your help.

This came up when i disabled "COFF" and restarted rhino and grasshopper again.

Did i install the plugins with the "?" wrong?

I got it solved.

You just need to copy the dll.-files mentioned in the "speech bubble" with the error warning from the component folder of grasshopper to the System folder of rhino where the rhino.exe file is.

At least that worked for me for two plugins that did not work. Then quit an restart rhino and gh and it should work fine.







  • Add Photos
  • View All

© 2021   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service