Grasshopper

algorithmic modeling for Rhino

So at first I thought Lunchbox was at fault for freezing the Grasshopper UI after using the Object save component (http://www.grasshopper3d.com/forum/topics/lunchbox-object-save-free...), but after just trying the same with Elefront I realised its doing exactly the same.

As soon as I use the Export component and it saves rhino geometry as a file (tried with .obj and .3dm) the Grasshopper UI partly freezes. Zooming in and out with the scroll wheel still works, the menu, saving, etc. still works. Just no more clicking inside the viewport of GH works. The export itself works fine though and the command line of Rhino says everything finished fine, just that I always have to unload and load GH again.

This is so strange and I am not sure whats at fault - Rhino, Grasshopper, Mouse Driver !? WTF!

I have tried it on a completely different computer though and its doing the same. 

Windows 7, Rhino 5.11, latest GH.

David or anyone else, any idea what could cause this?

Views: 1764

Replies to This Discussion

I think it's the fault of the Button object. Try using a boolean toggle instead and see if the problem goes away.

It does kind of work, but some plugins like FabTools will just keep on doing the same thing over and over and freeze the UI not allowing me to turn off the Toggle. So I have to keep clicking on it like a mad man in the hopes of hitting it JUST after it has completed calculation once.

It is indeed as Andrew mentions, the Button component.

I usually get rid of this, using an amazing workaround.

I left click on the canvas, whilst hitting the Esc button and cursing at the same time.

Trust me it works. 

@Marios lol

Tsss.. Button, you sneaky little bastard!

Thank you @Andrew and @Marios. It was just like you said! Well at least I am not doubting my sanity any more and can get on with stuff. Will use the toggle, even though that really doesn't make any sense at all for what I am doing - exporting geometry as a file, because you want to do that once and not overwrite the file every time the patch recalculates. But ok, I will find a solution. Maybe there is a sort of flip-flop switch that turns itsself off, I think Firefly has something like that.

I couldn't get the left-click, esc button trick to work though.

I am resurrecting this as it is super annoying and it would be nice to get an explanation as to why this happens and if this is getting fixed. To narrow down the problem - it is not ALWAYS happenign with a button, but it seems like its only happening if the button is triggering a plugin using rhinoscript, like object export, baking, etc.

I can confirm this also happens with FabTools.

David: Please tell us this is getting fixed at some point! I hate having to save, unload grasshopper and load it again, every time I press a button to export something out of GH!

I'll try to get around to this. Added a YouTrack item so I won't forget.

Thank you! :)

Armin,

If you read the description of the component input, you will see this warning:

That was the best I could do at that time.

Ok, I think I need to look at your descriptions more ;) Its a known thing, and as I said its happening in many other plugins too, so its not your fault. The problem is sometimes a toggle is not the right thing, as it will just keep doing something over and over, effectively blocking GH and having no way to turn it back off. This for example is happening in FabTools.

I wish there was a sure-fire-way of stopping GH. A bit like the timer block in the taskbar, but actually just stopping any GH components from doing stuff, especially if they are executing Rhinoscript functions, which cant be cancelled with ESC in GH it seems. The amount of times I need to force quit Rhino is too damn high.. Alas, the recovery function of Rhino and GH is the best I have come across and has not once let me down, so cudos to that!

I ran into this problem last week.  So I guess it has not made it to the top of the priority list yet.

I managed to create the attached as a work around to switch the toggle back off again.

Its doing what I want as a stand alone thing but I've not actually managed to weave this code into the rest of my definition yet.  So far its easier to just switch the toggle back off again.

RSS

About

Translate

Search

Photos

  • Add Photos
  • View All

Videos

  • Add Videos
  • View All

© 2024   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service