Grasshopper

algorithmic modeling for Rhino

Hello,

I just installed Mantis ON Revit 2015 works nice. But on the GH side it seams that something went wrong. I'm on a windows 8 machine runinr Rhino 5 and Lates version of GH

Thank you for youy help

Views: 645

Replies to This Discussion

So far I keep getting the same error. and for all components

Same for me... as of today.

Error message:

Runtime error (IOException): Could not add reference to assembly ProtoGeometry

Konrad: Do you think it has anything to do with changing from Dynamo 7 to 8?

Okay - I just found out that of course it has. 

Claudio: The current version of Mantis is probably written for Dynamo 0.7.

I don't know which version of Dynamo that you have. Remember it is nessecary to have Dynamo and the Mantis Schrimp package installed. 

I am not sure if the version of Dynamo has other consequences than the file path name. Konrad will know this. 

But to make it work yourself, you can change "Dynamo 0.7" to "Dynamo 0.8" and "...Dynamo\0.7\...." to ...Dynamo\0.8\..." in the Mantis GH Components and in the "mantisshrimp.py".

Rasmus, 

Huge thanks for pointing this out! I have been busy working on another plug-in and totally forgot to update this one to a new Dynamo version. Also, i will take a dig at Dynamo/Autodesk folks here for moving Dynamo folder location around like that every time they release a new version. It sux. 

I've tried to uninstall the component even in the dynamo side and reinstall them all following Konrad instructions. But unfortunately still getting the same results

Claudio,

I just published an update to Mantis Shrimp that you can get from Dynamo's Package Manager. This error was caused by new Dynamo 0.8.0 moving all of their files to a new folder location thus causing some errors when loading geometry libraries. Apologies for the delay. Let me know if it fixes the issue. 

RSS

About

Translate

Search

Photos

  • Add Photos
  • View All

© 2019   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service