algorithmic modeling for Rhino

Rhino will crash when running the outdoor airflow simulation with BF

Hi, Guys!

I tried to run an outdoor airflow simulation with Butterfly. My GH file was created based on the case file, and the case file could run correctly on my computer. When I run my GH file, several iterations were calculated and the Rhino crashed. 

If the size of my model is too big to be calculated? Any advice will be appreciated.


Views: 606


Replies are closed for this discussion.

Replies to This Discussion

Hi Yi,

I'm not sure if I replies to this question in another discussion or on GitHub. What is the model that you're trying to run and how many iteration is several iterations?


Hi Mostapha,

Thanks for your reply. the model I tried to run is the gh file in attachments. In fact, the problem had been solved after I rebuilt my gh file, although I don't know why. For the older gh file, after 50 or 60 iterations it would crash.

right now, I'm facing a new problem. I tried to optimize the maximum value of the wind speed ratio(WSR) in construction area with Galapagos. however, It seems that Galapagos can't wait to finish all the steps of calculation. In most situations, an individual generated by Galapagos can be calculated its mesh, but its mesh won't get though the simulation process. Galapagos won't wait to simulate but carry on with wrong data even if the WSR output will be "Null". 

I wonder that if you were caught in this kind of trouble? Could you give me some advice on this problem? Thank you very much.



Hi Mostapha,

Thanks for your reply. I have Updated my Butterfly installation using your attached file. But the last updated date is 2017-08-24 and when I tried SnappyHexMesh it showed me an error.

1. Solution exception:
--> snappyHexMesh Failed!
wrong token type - expected int32_t, found on line 107 the word 'L'

file: /home/ofuser/workingDir/butterfly/teaching/system/snappyHexMeshDict.castellatedMeshControls.refinementRegions.around_buildings_area.levels at line 107.

From function Foam::Istream& Foam::operator>>(Foam::Istream&, int32_t&)
in file primitives/ints/int32/int32IO.C at line 67.

FOAM exiting

If you know what wrong with my file? Thanks a lot.


And this is my file.







  • Add Photos
  • View All


  • Add Videos
  • View All

© 2024   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service