algorithmic modeling for Rhino

HoneyBee LabelSurface: 'Brep' object has no attribute 'Surfaces'

Hi guys.

Just starting to work with honeybee and I keep geeting this error when I try to label surfaces:

1. Solution exception:'Brep' object has no attribute 'Surfaces'

I even get it with the example files but I think everything is alredy updated so I don't know what I'm missing. Any idea?

Thanks guys

PS: Files attached

Views: 722


Replies are closed for this discussion.

Replies to This Discussion

Your file works fine with me:


Yeah... I assume it has to do with my installation or my computer.. But no idea what it might be.

Any idea?

Anybody an idea?

Might be a long shot, but perhaps you're running an old Rhino Service Release in which RhinoCommon does not have the Brep.Surfaces property yet (admittedly, sounds like a long shot, but perhaps).

Actually that worked! I was using an outdated SR.

Thanks a lot!

Hooray, glad it worked out :)






  • Add Photos
  • View All


  • Add Videos
  • View All

© 2021   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service