Grasshopper

algorithmic modeling for Rhino

Hi,

I've been using Honeybee for a while with EnergyPlus, but this is the first time I'm trying to export a file to OpenStudio in order to create an HVAC system. I am using the latest release of HB&LB (from last week). I've downloaded and installed OpenStudio 1.12.0 and made sure all the files are unblocked. Still, when I try to use the Export to OpenStudio component, I get the error

"Solution exception:The type initializer for 'OpenStudio.OpenStudioModelCorePINVOKE' threw an exception."

which happens at the line  "model = ops.Model()" in the script.

I've tried uninstalling OpenStudio 1.12.0 and installing an older version (1.9.5) but get the same error.

I've read through this thread (https://github.com/mostaphaRoudsari/Honeybee/issues/214) but am not sure how to fix it. Any ideas on what to try? Is there any way around this?

Just fyi, I am using a 64-bit Windows 7 Enterprise desktop PC. Thanks in advance!

Views: 2490

Replies are closed for this discussion.

Replies to This Discussion

Hi Julia, This is really unfortunate. There is not that much that us (Honeybee developers) can do in this case as the issue is generated somewhere in OpenStudio libraries. There are a couple of tests that we can do but again there is nothing major that we can do. The newer version should work without problems. Did you try to close both Rhino and Grasshopper and re-open the file after you changed the version?

Juila,

This is, indeed, very unfortunate.  We (Honeybee developers) have not experienced this bug for several versions of OpenStudio and we had hoped it was behind us.

Do you have any earlier versions of OpenStudio installed?  Or openstudio dlls in your ladybug folder? If so, please uninstall/remove them.

Just to be sure, can you upload your GH file so that we can be sure that the issue is specific to your system?

-Chris

Partly because I don't want to admit to myself that this OpenStudio bug has returned, I have been thinking of a scenario that could cause this to happen if someone was using an old version of the Honeybee components. Julia, if you can upload a GH file so that we can check the version of your components, we can find out if this is the case.

Yep -- will upload it tomorrow. 

See file attached -- let me know if there's anything to be done.

On that note, does the Export to OpenStudio component do anything different from  launching OpenStudio and doing File/Import/IDF file? (I know that just importing an IDF into OpenStudio doesn't import everything from the IDF file.) If you connect an HVAC system, does this export automatically create the system in the IDF or do you still have to do it in OS after? Thanks!

Attachments:

Julia,

Thank you for posting this. It seems the issue was as I feared.  All of the components in your Grasshopper file are up to date and your GH file is running fine for me.  So it is a bug affecting your system type just as the previous bug.

Would you mind opening the attached version of your file and let me know what the text in the panel is?

This will help me understand what version of OpenStudio the component is finding on your system.  Perhaps there's still a chance that it found an old version of OpenStudio somewhere.

-Chris

Attachments:

Also, Julia, I forgot to answer your question.  The Export to OpenStudio component is not not doing any heavy-lifting in writing an IDF.  Rather, it is writing an .osm file for OpenStudio using OpenStudio's API (this makes it MUCH easier to add detailed HVAC Systems to the model).  The component then uses the OpenStudio API to covert the .osm to an .idf that can be run through EnergyPlus.  This is a very different way of working than using the "Import IDF" functionality that you mentioned as this would probably reult in a lot of information loss, as you say.

-Chris

Hey, this is what I'm getting:

OpenStudio Library path set to C:/Program Files/OpenStudio 1.12.0/CSharp/openstudio/
Current working directory is set to:  c:\ladybug\test_1zone_ex\OpenStudio
Runtime error (TypeInitializationException): The type initializer for 'OpenStudio.OpenStudioModelCorePINVOKE' threw an exception.
Traceback:
  line 3528, in main, "<string>"
  line 3747, in script

And thanks for clarifying what the component does. If there's no solution to fixing this on my system, I guess I'll just learn to create my HVAC systems myself :). It's just annoying because I have to model one that doesn't come as an HVACTemplate object so it requires all the detailed inputs.

Julia,

Thanks for responding quickly.  This confirms that it is indeed the same exact bug as before but with the newer version of OpenStudio.  I have reopened the github issue that you cited at the top of this post:

https://github.com/mostaphaRoudsari/Honeybee/issues/214

We are going to need OpenStudio team's help to fix this and you can watch that github thread to see what they have to say.  Let's hope that it is not too long before we can get it fixed.

-Chris

OK, thank you! Hopefully something will get resolved!

RSS

About

Translate

Search

Photos

  • Add Photos
  • View All

Videos

  • Add Videos
  • View All

© 2024   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service