Grasshopper

algorithmic modeling for Rhino

The Ideastatica is in D:\Program Files\IDEAStatiCa\StatiCa9\

and Karamba3D is in D:\Program Files\Rhino 6

After run KarambaIDEA_Example_Truss.gh

  1. when drag "choosejoint" slider, no joint is shown in the rhino, which is opposite to what's shown in the video
  2. nothing is in the output folder

Views: 64

Replies to This Discussion

Hi Sean,

You could try the following installation procedure:

https://github.com/BouwenmetStaal/KarambaIDEA/wiki/Installation-&am...

With this procedure the source-code will be build in Visual Studio, producing the GHA component in the bin folder.

Best regards,

Rayaan

Hi Rayaan,

Actually, the KarambaIDEA addon is loaded into GH,an there is a tab called "KarambaIDEA" in GH.

But when run example, there is no ouput date in the output folder.

Do I need to change the following pathes in the visual studio to match the actual pathes on my computer?

* GH_IO                              path C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GH_IO.dll 
* Grasshopper path C:\Program Files\Rhino 6\Plug-ins\Grasshopper\Grasshopper.dll
* RhinoCommon path C:\Program Files\Rhino 6\System\RhinoCommon.dll
* IdeaStatiCa.ConnectionBasicTypes path C:\Program Files\IDEAStatiCa\StatiCa9\IdeaStatiCa.ConnectionBasicTypes.dll

Yes exactly.

This will cause that KarambaIDEA can find and use the dll's.

Hi Rayaan.


Im following the steps from the video. I don´t have Visual studio and in fact its first time i hear about it , so im not very friendly with it. Could you help me with this? i have uploaded an image which shows the options for downloading visual studio. Which one should i download in order to open SMARTConnection.sln? (its in spanish, but maybe you know with the logos). Once i have this clear and install, i imagine following the video steps (Which is perfectly explained) i will know how to proceed. 

Thankyou very much

Pedro

Attachments:

I think you only need the purple .net one.

Try it.

I have install visual studio and .Net framework 4.7.  I have also update in visual studio:

.GH_IO

.Grasshopper

.IdeaStatiCa.ConnectionBasictypes.dll

.RhinoCommon.dll

+ 3 other which gave me an error sign. (you will see in the images i update)

After following all steps, when i ran the truss.gha and press toggle it gives me the same error as the beggining. but this time it makes 3 files but not the statica file.

where do you think i have fail? you can see in the images i uploaded all steps i have done.

The only think i can think off is that i am running windows in bootcamp. (maybe thats the problem) and also, i didn't have the file with name Data. i just created and put there the template..(but i don't think this is the problem)

Any idea pleaseeee??

Thankyou very much

Attachments:

Set "Tester" as StartUp project instead of KarambaIDEA.

As described at:

https://youtu.be/uOJFbWMFe7k?t=372

Hopefully this will generate a file by raw data.

i have solved the problem.. i noticed that i had IDEAstatic 10 instead of 9. so i download it again, and finally works!! thankyou for your help Rayaan

Great!

RSS

About

Translate

Search

Photos

  • Add Photos
  • View All

© 2019   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service