algorithmic modeling for Rhino

Hi everyone,

Just building a simple catenary thingumy in Kangaroo, everything seems in order but when I press go, I just see a flicker of calculation and then my machine starts going very slow.

At first I thought that some lines might be breaking somehow, tried upping strengths, baking and then looking for it in the air but they seem to have completely vanished rather than just flying off into oblivion. 

Is it the fact that I baked everything before I simulated and so the anchor points are not listed correctly or something (I didn't think that it made a difference in the kangaroo solver).

Can someone have a look for me?

Thanks (I still can't believe there are amazing people in this world that will help me with stuff like this!),


Views: 533


Replies to This Discussion

Hello again everyone,

After going away from this and coming back with a fresh pair of eyes, I think this is a bug! There was a line that I hadn't quite trimmed up properly that was very tiny and causing kangaroo to delete the lines. When playing it back frame by frame on the animation solver, it appears that they disappeared radially from this 'bad' point. 

Redrew that part of the grid manually and seems to be working fine.

If anyone wants to look at this, I was using Rhino for Mac, otherwise, moderators feel free to delete/lock this thread.



Have you tried changing the tolerance?

using tolerance of 0.0001 everything works.








  • Add Photos
  • View All

© 2021   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service