Grasshopper

algorithmic modeling for Rhino

Hello Daniel i have downloaded and installed Kangaroo 2 but i cant interact with the rhino viewport, i have installed rhino 5 64 sr11, both files are unlocked, do you have any idea why this happens?

Views: 28984

Attachments:

Replies to This Discussion

Hi Daniel, 

Thank you for your quick reply. I tried turning off the COFF to get the mouseclick events to work, which then removed/unloaded(I do not know the right term for it) lunchbox,kangaroo 2 and human(the plugin not me). You know when you get a pop-up saying you are mising components when you open grasshopper.

That's strange, Kangaroo2 and Lunchbox load fine on my machine with COFF switched off.

You could try changing the settings for the different plugins individually, as David describes here:

http://www.grasshopper3d.com/xn/detail/2985220:Comment:1210822

So:

  • Help>About from Grasshopper
  • Click the tiny black box in the top left of the About window
  • Find the green box icon for Kangaroo2Component and double click it
  • The black Jigsaw piece icon lets you choose the loading type. I think you want Force Direct for Kangaroo2, and keep the default as whatever was working before for your other plugins

I also have the same problem after COFF being switched off, but in my case Elefront and Lunchbox have completely disappeared and few Sonic components had version conflicts, while Human seems to work fine.

Hi Anton,

Have you tried changing the loading type just for Kangaroo2, following my instructions here?

Hi Daniel, 

I am still having troubles with the mouse interactions(I will admit I havent tried what you are suggesting above) but do you think it could be because I am potentially on network drive - you know office computer? I will try your suggestion now though:) and keep you updated :)

I get this error;

Message: An attempt was made to load an assembly from a network location which would have caused the assembly to be sandboxed in previous versions of the .NET Framework. This release of the .NET Framework does not enable CAS policy by default, so this load may be dangerous. If this load is not intended to sandbox the assembly, please enable the loadFromRemoteSources switch. See http://go.microsoft.com/fwlink/?LinkId=155569 for more information.

which I assume mean that I need to install the newest version of .net ?

Some things to check:

  • dll and gha files unblocked
  • Rhino5 64bit SR10 and GH 0.9.0076 or later
  • .NET framework 4.5 or later
  • COFF loading turned off (either the global setting or just for Kangaroo2, following the instructions above)

Also - you say you are on a network drive. Is your Grasshopper components directory at least on your local machine?

If not, try putting the Kangaroo2 files in a local directory and adding that folder in the GrasshopperDeveloperSettings

Thank you I got it to work now :) 

It seems disabling this also removes some features from GH as others have reported? I'll wait until this can stay on and grab to work.

WTF?! It works. Who would have ever gotten this to work without that?! Does everything have to default to fail in this world?

Daniel, this is so incredible.

And I can´t believe the speed K2 is working with.

Really, really impressive.

Wow.

Daniel

I still have problem´s with gaping particles  in rhino view port,

I sow the video you indicate and  i was using the CRTL Left with LMB

but it does not work!

I update the .net

I did all the ritual:

  • dll and gha files unblocked
  • Rhino5 64bit SR11 and GH 0.9.0076 (evaluation version)
  • .NET framework 4.5 or later
  • COFF loading turned off (either the global setting or just for Kangaroo2, following the instructions above)
  • I´v my kagaroo2 dll and gha files in local machine

I worked at windows 8.1 (64 )and windows 7 (86)

The kagarro2  work´s in these machines without problems

only the Grap component does not work...

I´d an educational  lab licence for Rhino, and I´ll try to work with another one maybe it does not work with newest release, my licence is SR 7

I install the Rhno 5 version SR11 but will expire in 30 days

RSS

About

Translate

Search

Photos

  • Add Photos
  • View All

© 2019   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service