algorithmic modeling for Rhino

I kept getting this error when trying to use Doodlebug: Solution exception:Retrieving the COM class factory for component with CLSID {B0D0A647-983E-485B-9A69-45F0382F0D9C} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)). I'm not familiar with a lot of the magic and programming languages behind how this plugin works between Rhino and Illustrator, but I did a bunch of prodding trying to find a way to use Illustrator CC 2017 with it.

In the end I couldn't. But I installed CC 2015 (19.0.0) and it worked perfectly. This is on my personal laptop running Windows 10, with Illustrator installed at its default position on the C drive. No other more recent version worked for me, but I think that's more of a problem with my own dying laptop.

Views: 3181

Replies to This Discussion

Unfortunately COM interfaces - the mechanism I'm using to connect to illustrator - seem to be *extremely* finicky about application version. Unfortunately the *only* way I know to get doodlebug to work with a different version of illustrator is to build it from source ( against the COM library on your machine, which I fully recognize is not especially accessible to everyone. However, I know of no other way, and I cannot really help since I only have one version of illustrator on my own machine to build against.

Thank you for replying personally so quickly, I'm going to give that a try right now. Doodlebug is a bit of a gamechanger and I was stuck on that for a long while, looking forward to getting things running in time for the semester.

if you do plan to try to build it from source, let me know if you need any assistance. 

I took a bit of trial and error and googling but I fumbled my way through and got it working, thanks again for uploading the source and thank you for the offer.

I'm not sure if it would help, but here's a dropbox link to what ended up working for me: CC2017.0.2 If I ever have to rebuild again I'll add those versions in, too.

Hey Chuck,

How difficult was it to edit the code. I'm having the same problem with the versions not matching up and am interested in doing this.


Sorry for the huge delay, I don't check here often.

It's only a few clicks overall, but it's super picky about getting it right. I can take some screenshots when I get home that might help.

I used Visual Studio. You have to change the Illustrator reference from Andrew's Illustrator to yours: (C# Program Instructions) There's two files that need to have this adjusted, if I remember right.

Then you just press "build" and Visual Studio should handle the rest. You'll end up with a .gha and a .dll that can be put in the Grasshopper components folder.

I hope this is readable/helpful.

Thanks for the reply, Chuck. So I tried to follow your directions, but for some reason I seem to have things unlinked that you don't. Also, when I browse to the Illustrator COM, It adds a new reference rather than relinking Andrew's original "IllustratorInterface". When I rebuild I get quite a few errors and maybe it has to do with the unlinked COMs. Do you have any advice? Disclaimer: I have no idea what I'm doing haha.

Completely forgot, I ran into that too. You have to do the same process for Rhino, Grasshopper, and GH_IO as you just did for Illustrator. Rhino should be in the same list, titled as whatever version you're running. If you click Browse, in that same reference window, you can manually grab the grasshopper files. Mine were in the Grasshopper folder at "%appdata%\McNeel\Rhinoceros\5.0\Plug-ins". (Should be Grasshopper.dll and GH_IO.dll)

You also need to fix the Illustrator reference in "IllustratorInterface" the same way you did for "Doodlebug." It should show up if you scroll down the menu to the right, and it will have its own reference tab. (It's not the one you see right now under Doodlebug's references.)

About to go to class. If that doesn't work I'll take more screenshots later today. 


Should I remove the reference to "Illustrator" then add "Adobe Illustrator CC Type Library" under "IllustratorInterface"? If I try to add the Illustrator CC library found under COM, it says I already have that and need to delete "Illustrator" to continue.

I'm not sure, to be honest. Here's a screenshot of what my references look like, hopefully that clears things up a bit:

If not, I have a plan B we can try. And sorry this is such a bumpy process. I don't completely understand how I got it to work and am retracing my steps as best I can.

What you wrote last sounds like the right step, though.

Can you teamviewer to help me improve my problem with  IllustratorInterface in Visual Studio ?






  • Add Photos
  • View All


  • Add Videos
  • View All

© 2021   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service