algorithmic modeling for Rhino

Hi all,

The new Chameleon ( is finally here, check it out!

  1. Chameleon now supports editing adaptive components it has previously placed.
  2. Chameleon Adaptive Component Systems (CACS) can be created, named, and edited later, (Added “AC Connect”, “AC System”, & “Load AC” functions).
  3. CACS created in one session of Revit can be re-loaded into the Grasshopper environment in another session.
  4. Utility commands in the Grasshopper & Revit environments have been de-commissioned, to reappear in a separate plugin.  Chameleon is focused on interoperability.
  5. The GBXML component now works without needing proper latitude, longitude, & city data.



Views: 4399

Replies to This Discussion


Hi Hiroshi

I have been using your chameleon 3 plugin quite a lot lately, and was very excited to hear of the release of ver 4.

I tried downloading it a few days ago, but you havent replied to my request (sent from my mail).

whats up?



Hi Guy,  The download is displayed on the website when you enter your information, you shouldn't need to wait for me to email you. bad

Thanks for the great software!!!



Awesome plugin! I've been experimenting with it for a project and so far so good... mostly. First, I tried with Revit 2014. It worked well for the first batch: ~7,500 adaptive components placed with one extra parameter. Then the next batch, same file: ~7,000 adaptive components placed, but Revit was frozen when it finished.

The project is actually on Revit 2013, so I wanted to start using the actual panelization scheme and bring it into the real RVT project. Only problem is, when I go to install the GH component on this new machine (a co-worker's machine who is using 2013), HIJAC doesn't show up!

Any help would be greatly appreciated.



As you can see, the GHA file is in the folder and I've restarted Grasshopper and Rhino. No HIJAC. Any suggestions would be greatly appreciated.

Hi Hiroshi I have Revit 2014 installed. I downloaded Chamaleon and I also tried with I got to install them in Grasshopper but none of them in Revit. I run the install file and I have also tried to copy the files in C:\Users\Usuario\AppData\Roaming\Autodesk\Revit\Addins\2014 and it does not work at all I´m not getting the Chamelon tab in Revit. Suggestions?


Hi Owe,

The Chameleon commands are located on the Add-Ins tab, have you looked there?

Of course but they are not there, not in my Revit. Chamaleon works for Revit 2014 right?

So, finally I got to instal Chameleon in both Grasshopper and Revit but when I try to run it it promps this message: "Waiting for Revit to connect... Please activate the Place Adaptive Components in Revit" and it gets blocked... What I am I doing wrong?

Hi Hiroshi!!

To transfer geometry from Grasshopper to Revit using Chameleon you have to load first an adaptive component to a project template in Revit, right? If that is the case, which sort of adaptive component do you need in relation to the geometry you want to import? Can you bring geometry from Grasshopper to a family or generic model adpative template in Revit instead, or this is it mandatory to use a project template?


hi hiroshi. sorry to bother you but i cant seem to get revit 2013 to recognize the ChameleonRVT.dll. Ive run the setup exe... and installed the unblocked files it in the folder :C:\Documents and Settings\MY NAME HERE\Application Data\Autodesk\Revit\Addins\2013. It gives me the message Failed to initialize the add in "chameleon" because the assemby "Release\ChameleonRVT.dll" does not exist. Any advice is appreciated. I'll keep trying and let you know if I figure it out Thanks -Ethan






  • Add Photos
  • View All

© 2023   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service