Grasshopper

algorithmic modeling for Rhino

Hi,

  I'm having a bit of an issue with sweeping multiple curves.  The way I have my data set up, each rail curve gets paired with two cross section curves.  Then they get put through the sweep function.  However, I'm getting some very odd results.  I was hoping to get some insight on the problem.  Thank you!

Views: 614

Attachments:

Replies to This Discussion

After Graf Mapper you graft cross sections curves... Why?

I removed the graft, but I still get some very odd results.  It now creates 5 output paths, as it should, but only three are successful, even though I can perform the sweep on all 5 sets of data individually.

Screenshot would be helpfull...

Okay, two screenshots - one in which the rail is grafted, one in which it isn't.  I also included an example of applying the operation to one rail/cross-section set, in which case it works fine for all 5 combinations.

Attachments:

Also, here is the 3dm file I am using.

Attachments:

1) You cross section curves has invalid direction.

2) And ... I dont know how to finish solve the bug (as I think)...

Look at the definition. And try to do it in Rhino and you will see the problem...

Attachments:

That is amazing!  Thank you for doing all of that work!  I didn't know you can move the seam/direction without VB Script.

Using your logic, I was able to figure out why the last curve wasn't sweeping - it was the only one that didn't need to be flipped.  Attached my solution, mostly for people who will search through this later.  Большое спасибо!

Attachments:

Хрен его знает, получится ли с последней кривой. Там всё таки какой-то баг...

RSS

About

Translate

Search

Photos

  • Add Photos
  • View All

Videos

  • Add Videos
  • View All

© 2022   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service