algorithmic modeling for Rhino

I've started this discussion so I don't bother the discussion about the new v0.90065 release...

The thing is that I'm having problems with the Ribbon Layout.

Probably it got broken, but I've re-installed it like 3 times now and isn't still working

The problems are that my custom layouts don't work anymore. Apparently they're empty

And when I'm trying to create a new one, the editor doesn't let me put any panel with any items into the white space to order them...I first have to clear the panel from all the items and then I can place the panel below.

If I don't do this way, the panel will just dissapear into the cosmos...

Besides (just to finish...) if I try to put a whole tab in the white space below (it may be some kind of devil) just says there are no items at all in it...

thanks in advance

Views: 1083


Reply to This

Replies to This Discussion

Hi Pablo,

it's a bug. I've fixed it and it will be released as part of 0.9.0066 (or Grasshopper 1.0 Beta 2)


David Rutten

Thank you David!

better now, I felt kind of dumb...just will wait for the new release

I have the 0.9.0066 GH release, yet my Ribbon layout is still not working.  I create a new layout, I try to add it yet nothing changes.  When I try to open and edit that layout again it won't open to edit.  I checked the version release notes and it says ribbons were fixed, so not sure if there is another bug or mine just didn't work.

edit:  I am attempting to edit the layout to have panels for DIVA, Ladybug, and Geco in the same tab, so not sure if maybe its just not possible to combine/edit those like that?

Does it say 0.9.0066 on the Grasshopper banner? The release notes are downloaded so they show the most recent ones no matter what version you're actually running.

Also can you upload your layout file so I can test it here?


David Rutten

I have the 0.9.0075 GH release, yet my Ribbon layout is still not working. I create a new layout, I try to add it yet nothing changes. When I try to open and edit that layout again it won't open to edit.

some panels are visiable,but some panels are invisiable!

That is because Ladybug works with userobjects instead of .gha files...

userobjects won't appear in your new layout (I guess they're only configurated for the default layout) unless you put them in its place...

Oof yeah I can confirm - you can see in the img below I tried to make a "BldgPerf" tab w/DIVA, Ladybug, Honeybee, and Geco. Because Ladybug and Honeybee are User Object collections they disappear from the ribbon upon relaunching Grasshopper after the initial ribbon creation.

In fact, all user objects disappear - the ones in their native tabs (Bumblebee, FabTools, etc.) AND the ones in new tabs of my creation.

I'm not actually sure of the best way to fix this. Reloading the user objects to the directory doesn't work. I assume a reinstall of Gh would do the trick but I wonder if anyone has another method.

Mmm...I'm not sure reinstalling GH would work,

anyway, I don't know how solve this, nor even if it can be done,

maybe in a new release this could be taken into account...

Turns out it's an easy fix. Close Rhino/Gh, delete grasshopper_ribbon.xml from C:\Users\%userprofile%\AppData\Roaming\Grasshopper, and then relaunch Rhino/Gh. Grasshopper will automatically generate a fresh ribbon XML file in the directory, which looks like this (in case you'd prefer to edit the file rather than delete/regenerate it):

<Fragment name="Settings">
<items count="1">
<item name="LayoutCount" type_name="gh_int32" type_code="3">0</item>

I suppose an alternative would be to back up the original ribbon as a *.ghlayout prior to creating a customization so that you have something to which you can revert.

oh, I hadn't thought about that looks like it may work

thank you Brian!

I can't customize my layout! Why?? 

I've used Brian solution, but nothing...






  • Add Photos
  • View All

© 2019   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service