Grasshopper

algorithmic modeling for Rhino

Hi everybody,

I have got a problem with HoneyBee_RADParameters component, because when i change the default inputs (like _ab_, _ad_, _as_, ...), even if the output "out" shows the inputs i have changed, during the simulation i can see from the black window of the radiance simulation that i still have default values, excepting for ab that is changed.

I have also checked the "range" of the values according to radiance and the values i put are in the domain so i may exclude that problem.

Do you know where is the problem? What do you suggest?

I hope you´ll help me to solve this problem because it should be a way to decrease the time to run a daylight simulation!!!

Thanks a lot in advance

Claudia 

 

Views: 622

Replies are closed for this discussion.

Replies to This Discussion

Hi Claudia,

What type of analysis are you running with Honeybee? ImageBased, GridBased, annual?

I did a quick test for imageBased analysis and the file is generated correctly. To check the parameters you can open the studyFolder (it's one of the outputs of run daylight analysis component.) and  check *.bat files. There is a rpict or rtrace line that you can see all the parameters listed. Mine is: 

rpict -i -t 10 -vtv -vp 43.111 -74.673 49.782 -vd -0.433 0.750 -0.500 -vu 0.000 0.000 1.000 -vh 54.328 -vv 26.991 -vs 0.000 -vl 0.000 -x 64 -y 64 -af unnamed_IMG.amb -ps 8 -pt 0.15 -pj 0.6 -dj 0 -ds 0.5 -dt 0.5 -dc 0.25 -dr 0 -dp 64 -st 0.85 -ab 2 -ad 20 -as 128 -ar 16 -aa 0.001 -lr 4 -lw 0.050 -av 0 0 0 unnamed_IMG.oct > unnamed_IMG.unf

aa and ad values are changed in this example.

Mostapha

Hi  Mostapha,

thanks a lot for you email! I´m running a daylight factor analysis as you can see from the screenshot above.  

Thanks for your suggestion of the .bat file but i have checked it and i still have the problem.

Do you think that the "-u" value as input of additionalP (for stoppping the stochastic randomness) could cause the problem?

Thanks a lot in advance

Claudia

It happens the same to me. When I run Daylight Factor analysis the only parameter that changes is the "ab". All the other parameters are fixed.
Claudio

I add some screenshots as well.
Even with the preset for the low quality:


You can see that in the read me panel it says that there are some preset values but then when the simulation run, only the ab value is the right one and can be customized:
ad 1000, ar 300 and aa 0.1.

Thanks in advance,
Claudio

Hi Caludia and Caludio,

Ok! That helps. It's because Honeybee's internal check of the parameters to make sure the quality meets the minimum accuracy. If you check readMe! on runDaylight component you'll see something like this:

If you change the parameters to be more than minimum then you will see the change in the batch file. Check this discussion if you like to stop the internal check.

Thanks a lot Mostapha, that makes really sense!
Cheers,
Claudio

Hi Mostapha,

Thanks a lot for your reply.

I followed the other discussion and i did what you suggested (to put # before the sentence hb_writeRADAUX.checkInputParametersForGridBasedAnalysis) but i still have that problem. I still have other values in the .bat files

Do you know why?

Thanks a lot in advance

Claudia

Hi Claudia, Can you update an example file with a simple model and I will take a look.

RSS

About

Translate

Search

Photos

  • Add Photos
  • View All

© 2021   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service