Grasshopper

algorithmic modeling for Rhino

Hi all,

I am new to grasshopper and while I was installing, I got the following error message.

Object: GalapagosObject (level 1)

Exception has been thrown by the target of an invocation.
{TargetInvocationException}

Object: GalapagosObject (level 2)

Could not load file or assembly 'Galapagos, Version=1.0.0.0, Culture=neutral, PublicKeyToken=dda4f5ec2cd80803' or one of its dependencies. The system cannot find the file specified.
{FileNotFoundException}

Is this something I should worry about, because when I close the dialogue box, the grasshopper window appears with all its components.

Any help will be highly appreciated.

Thanks,

Jude. 

Views: 2095

Replies to This Discussion

Hi Judhajit,

very odd, it would seem that Galapagos.dll is not found. It should be part of the installer. Which installer did you use?

--

David Rutten

david@mcneel.com

Poprad, Slovakia

Try replacing the Galapagos.dll on your machine with the one attached. Maybe it will help.

--

David Rutten

david@mcneel.com

Poprad, Slovakia

Attachments:

Thanks David for attaching the file. It did help :) It seems that there was no "galapagos.dll" file in the installer. 

Regards,

Jude. 

That is really weird. Glad it worked out though.

--

David Rutten

david@mcneel.com

Poprad, Slovakia

David,

I got the same exact error message. I downloaded your attached Galapagos.dll and put it in the directory "grasshopper_0.9.56.0" and the Rhino directory "Plug-ins". I could not get the error message to go away. Perhaps because its an evaluation Rhino license??? I know nothing about Rhino or Grasshopper. The reason I downloaded Grasshopper was to get involved in help scripting for 5 axis gcode. Any help would be very much appreciated.

 

thanks....ken

I guess this is my BIG welcome to Grasshopper community. I was thinking about buying Rhino and using the Grasshopper plugin but I see the wonderful support I get here. I am new to the cnc world but I am not new to 3D design. I have used AutoCAD for 3D work for almost 20 years and have a degree in mechanical engineer and civil engineer with engineer licenses in 8 states. Also I know VB and C programing. Since my plans are to use 5 axis cnc machine to develop some ideas of mine I was encouraged to get involved with Grasshopper in developing 5 axis gcode for the Grasshopper community. But since there are no replies to a simple question I see that this was a complete waste of time...just glad I found out now before I studied up on Rhino and Grasshopper. It was fun my friends... : )

wow, you seem to have taken it a bit too personally.

There are several things going on here. 

1) The forum "Errors, Bugs and oversights" would have been a better place to put this as it wouldn't have been lost in the intense activity that goes on in this very welcoming and helpful community.

2) No one else in the GH community could probably answer this apart from David, The sole developer of Grasshopper.

3) David is in the process of not only moving house but also countries at the moment.

4) Time zones

A simple "bump" to bring this back to the top of the discussions would have been politer.

To put into perspective

Grasshopper has 1 developer.

there have been 426 new items of activity on the Grasshopper Forum in the last 24 Hours.

Autodesk has 7800 employees (don't know how many develop AutoCAD specifically)

There has been 57 new items on their forums in the same 24 hr period.

If David hasn't replied to this in the morning I will bring it to his attention.

Sorry for sounding so sour :(    I am very new to Grasshopper so I had no idea that David was the only one who could answer my question. I know it must be a pretty good program with all the members. Wish I had waited a little longer to reply. David is very busy and to be honest I am glad he did not answer with all that he has going on. I see that Grasshopper is going to be updated soon so I will wait and down load it after the big revision. There is no way I am the only one who had the Galapagos bug and sure it will be addressed. I now know where to post bug issues. Thank you very much for replying and I deserve to be put in my place! I truly apologize and hope to be using Grasshopper soon. I really do love programing and hope to contribute once I get Grasshopper up and running. Are you sure you spelled your last name correctly Boyes....  : )

You can tell it was late last night when I posted a reply. This is in Errors, Bugs and Oversights.

:)

Hi Ken,

I missed this part of the discussion. Galapagos.dll needs to be next to GalapagosLibrary.gha

If it's not then there will probably be a FileNotFoundException.

It is very odd if the file isn't there though, they should both be installed simultaneously from within the same installer. If this doesn't happen, we'd like to know what might be going wrong here. If you download the latest installer, run it and it still doesn't give you Grasshopper.dll, please send the install log to my email. You can find the install log in: %appdata%\McNeel\Rhinoceros\5.0\logs\

Sort by date and find the most recent file called Grasshopper (<date>-??????).log

As Danny mentioned, I'm in the middle of an international moving operation right now so support will be slow to non-existent for the next 2 weeks.

--

David Rutten

david@mcneel.com

Poprad, Slovakia

Hey David,

I down loaded the installer again and this time it worked! I have no idea what I did wrong before or did right this time. Hope the move goes as good as possible...if I was close I would help with the move. Sorry again for making a#s of myself. Thanks for the help!

RSS

About

Translate

Search

Photos

  • Add Photos
  • View All

© 2021   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service