Grasshopper

algorithmic modeling for Rhino

I was trying to use the mesh eval component, but it asks for a mesh parameter (which doesn't exist). I've tried multiple inputs, but none convert to a mesh parameter. Has anyone successfully used this component?

Views: 6886

Replies to This Discussion

Mesh CP will create a Mesh Parameter. Mesh parameters are complicated, they have a face index and then barycentric coordinates for within that face. And the coordinates have to make sense both for triangles and quads. 

--

David Rutten

david@mcneel.com

Poprad, Slovakia

Thanks David!

Hi David,

this seems to be broken for unwelded meshes, I just forgot to tell until I tried again today.

Rhino crashes with a 'Send Error Report' Message, nothing else, as soon as I plug in the parameter into the eval component.

If I weld the mesh before, it works.

best,

robert

PS the internalized values in Add-components still vanish sometimes, sometimes they dont. either when copy/pasting the components or when saving and reopening. 

another thing regarding the eval Mesh component - the color output yields null for my colored mesh, the others work fine.

both for my karamba mesh, as well as an arbitrarily coloured mesh plane.

thanks a lot,

best

R

Hey Rob!

I guess I read David say somewhere that this frustrating color problem was an issue with the current release of rhinoCommon, so I came up with a quick and dirty hack for the time being.

The trick is to make a new mesh and replace its normals with the color from the old mesh, and then evaluate that. It will make an invalid mesh, but will do its job for this purpose with no problem.

Check the attachment.

Cheers.

Attachments:

This is fantastic- thanks!

great works on a bitmap mesh also

Hi David,

any chance you could fix this in a future release? my rhino still crashes on some cases. couldnt really find out what the driving factor for failure is.

in another case the mesh eval just gave wrong results it seemed.

see attached file!

thanks a lot,

best 

Robert

Attachments:

indeed. the eval mesh component outputs only nulls for "colour at mesh parameter"  

any fix yet?

which component should I put in the the 'Parameter'?

RSS

About

Translate

Search

Photos

  • Add Photos
  • View All

© 2021   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service