Grasshopper

algorithmic modeling for Rhino

Hi all,

I have two sets of curves I want to loft. One set in at the botom and the other set is on a surface which I offset.

I have tried Sorting lists and reversing lists and grafting and flatening branches but could not get the lofts to work out. It is almost always the same three cruves at the top and botom which don't loft like the rest (just directly to apposite curve).

Any help will be greatly appreciated. Thanks

Theunis

Views: 519

Attachments:

Replies to This Discussion

The param viewer shows that the loft component produces 8 surfaces, even though you are feeding it 11 + 11 curves. If you look at the paramviewer attached to the curves you'll see that 6 of the curves are on their own paths, but the first branch contains 3 curves and the second one 2 curves. If you want the same result for all pairs of curves you'd need to split up the first and second branches, so that all curves are on their own branch.

Hi Lars,
thanks for the reply, im sorry i have added a new photo which is a more accurate presentation of my problem.

I have tried grafting the paths to make each data item its own path, then loft between those to graft components, but 4 of the curves always give me a strange result.

I need a way to properly sort those two lists of paths that they loft in the right order/sequence.

I have a hunch sort list component will be the answer but I am not sure of how the component sorts a list using the input "K". I don't quite understand what I should feed into the input slot "K"("Sort.K").
The image size is to small for my eyes, could you upload it again. In the dialog box that opens, select Options and tick Pop-up window.
Sorry for that, I think the file will serve you beter.

My problem area is under View - loft problem
Just set one planar surface for parameter under View - Set 1 view

thanks
Since I don't have your original curves, everything looks good...


My guess is that things will work like you expect if you right-click the D-input of the Graft-components and select Flatten. (I haven't done that, but I'm just referencing 3+3 curves).
Nope I tried flattening before, didn't work, I get the same result.

But thanks for the effort.
Don't worry about it further, I did 3 separate lofts to get the desired result.
Great, didn't realize at first that what I saw was just a tiny bit of the definition, but it's nice to hear that you figured it out.
Or so I thought, same problem just now with one of my 3 separate lofts, grafting and flatening still not working.

RSS

About

Translate

Search

Photos

  • Add Photos
  • View All

Videos

  • Add Videos
  • View All

© 2024   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service