Grasshopper

algorithmic modeling for Rhino

How to reconcile data outside/inside cluster? Data lost in translation when it comes out of cluster.

Hi all,

I have had this problem before. Data in the cluster does not match data outside cluster. How to reconcile them?

Thanks,

Views: 152

Reply to This

Replies to This Discussion

Try removing existing Cluster Outputs and putting new ones.

Does this happen after editing? After creating a cluster anew? Does it still happen if the file is saved, closed and re-opened?

So I jumped the gun because I have had this issue in the past. Particularly pertaining to null values and empty trees.

As it turns out this time I cried wolf (sorry) before inspecting thoroughly. My inputs are in fact equal to my outputs. Will raise this issue again in the future if I encounter it.

Thanks,

M

The reason this occurs (when it does) is that empty branches seem to "disappear" when you view the inside of a cluster. http://www.grasshopper3d.com/forum/topics/cluster-input-removes-emp.... Wombat "insert nulls in empty branches" is specifically designed as a way to get around this problem - nulls will be preserved in and out of the cluster.

I have had a similar problem after editing a cluster. I have tried:

  • replacing output component
  • unloading grasshopper and reopening
  • closing rhino altogether and re-opening

Still, the data outside the cluster for some reason has two Nulls, while the data inside the cluster has none. Any ideas?

Capture.JPG 
Capture%202.JPG

Thanks,

Lia

RSS

About

Translate

Search

Photos

  • Add Photos
  • View All

© 2019   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service