Grasshopper

algorithmic modeling for Rhino

Hi everyone!

I'm getting an error and a warning when exporting to openstudio: 

  • 1. Failed to find DEFAULTCSVPLACEHOLDER in the Honeybee schedule library.
  • 1. Solution exception:'NoneType' object is unsubscriptable

Does anyone have any thoughts on how to solve this?

Gr,

Sam

Views: 825

Replies are closed for this discussion.

Replies to This Discussion

Sam,

You can see here (https://github.com/mostaphaRoudsari/Honeybee/issues/161) that this results from the fact the OpenStudio does not currently support the use of CSV schedules and we have to write a work-around in Honeybee to be able to get your Honeybee-assigned CSV schedules to be in your energy model.

To get rid of the component failure in your image, you are going to have to replace the 'OpenStudioMasterTemplate.idf' in your ladybug default folder with the one on the github here:

https://raw.githubusercontent.com/mostaphaRoudsari/Honeybee/master/...

I apologize for this extra step but this implementation of CSV schedule capability on OpenStudio was really meant to be a rough hack until the OpenStuido team implements this capability on their own software and SDK in a year or so.

-Chris

Hi Chris,

I was chearing a bit to soon as I've ran into another problem a bit run into another problem: I'm recieving severe errors which state that I'm giving an invalid schedule name. When I open the IDF I see that the Schedule:file section is empty whilst I've set schedules to each zone using the setEP zone schedules component. I've also tried updating this component to the March 14th 2016 version from github but this has not been succesfull

Do you have any ideas? 

Gr,

Sam

Hi Sam, There is an error in your schedule. Are you changing the schedule for occupancy?

Hi Chris!

I have the same problem! (1. Failed to find Office Bldg Light in the Honeybee schedule library. - 1. Solution exception:'NoneType' object is unsubscriptable). 

I have tried to replace the 'OpenStudioMasterTemplate.idf' in my ladybug default folder but this  doesn't seem to change the things.

By now I am only trying to open your "Trees_in_Outdoors_Thermal_Comfort" so the problem is not a mistake in the workflow.

Thansk a lot,

Irene

Irene,

This is a different issue than the one at the top of this discussion.  Do you see that Honeybee_Honeybee had loaded in the schedules like so:

-Chris

Hi Chris,

Thanks for the quick response, unfortunately I haven't understood what I should do to fix my problem!

This is what i get when I open it!

Thanks a lot,

irene

Hi Chris, I miss the scheduless! How can I fix it?

Attachments:

I would open a new discussion for this.

Hi Chris, 

Thanks for the quick response. You suggestion fixed the problem. 

Gr,

Sam

RSS

About

Translate

Search

Photos

  • Add Photos
  • View All

© 2020   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service