Grasshopper

algorithmic modeling for Rhino

hello,

in some details the clustering function does not work as expected. In the forum there are several posts regarding this topic, so I try to explain the issues that I'm confronted with. For easier reference, I uploaded a testfile with labels A to F that shows this issues.

When selecting some objects and pressing the middle mouse button, a button for clustering appears. The inputs and outputs of clusters created with this immense useful function cannot be tagged.

1.
Set up a cluster like in A with inputs/outputs, tag the inputs/outputs with double click, cluster it, the inputs of the clusters B are correctly labeled.
double-click the cluster to edit it, double-click the input to edit the label, edit, save-and-close cluster - the new label doesn't appear at the input. Maybe I'm doing something wrong?

2.
select the objects to be clustered like in C, middle-mouse-button, cluster selection, the result can be seen in D. Again, double-click the cluster to edit it, edit the labels - nothing happens.



3.
This has to do with the visibility of clustered components. E shows two clusters that cannot be displayed, no matter if they are set to visible or not (it's the same component imported from my library, copied, disentangled and made inside visible one time). I believe I created it like method C.
I tried different cases (that's why there are so many differently visible variations in the file), but cannot reproduce this error.


best regards, Laurenz

Views: 2134

Attachments:

Replies to This Discussion

it seems that there is not to much interest in this topic, but here is another one regarding the same topic:

when changing the input/output AFTER the cluster is created, on the outside of the cluster the old type remains. (In the second image the popup should show "Crv" since it was connected to a curve-component)

Here a working workaround:

Inside the cluster (GH shows blue background):
• (Double click and) edit the descriptions for in- and outputs manually.
• Select all (Ctrl + A)
• Copy (Ctrl + C)
• Right click the box in the left top corner of the canvas and select "Discard and close".
    (May ask you if you want to save changes (even if you haven't made any) - Say "No"
• Once you're back in your definition - Paste (Ctrl + V)
• With all (pasted) components still selected - hit the spacebar and select the 'Cluster' icon/button.

* You can then right click the cluster to set some properties (name, description, icon and so on) by selecting... "Properties..."

I've had the same issue, driving me crazy on a multiple clusters with 20+ outputs.

I don't have a fix, but wanted to support you! You're not going crazy!

I too have this issue!  I'll report back if I find something.  Cheers!

RSS

About

Translate

Search

Photos

  • Add Photos
  • View All

© 2024   Created by Scott Davidson.   Powered by

Badges  |  Report an Issue  |  Terms of Service